Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category
  • Assigned To No-one
  • Operating System
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by slimx - 2006-02-22
Last edited by ssnajper - 2006-02-23

FS#3058 - working rockbox with button for iPod 3G

try it and smile :)

   patch.txt (39.3 KiB)
Closed by  linuxstb
2007-02-17 02:46
Reason for closing:  Accepted
Additional comments about closing:  

This code must have been committed in the past…

Thanks for your unbelievable work slimx!

Can you please get this added to cvs and make a 3g
bootloader so it will be more simple to install? (with a
seperate daily builds for 3g)

Thanks a ton once again!

I’ve uploaded a bootloader to the Ipod Install wiki page. It works for me, so it should be fine for all 3Gs. If you have a problem, let me know, or just build your own (instructions are on the wiki, and compared to adding that patch, its painless :) )

slimx commented on 2006-02-23 22:49

I don’t know how daily build works, and i have no cvs write access.
but i agree mike it will be much simpler to install and try.
you can find my bootloader here and i’ll add my current rockbox.zip
so it will be easy for users …..

Project Manager

I’m adding a 3G build (and bootloader) right now.

Project Manager

But then of course, it doesn’t build fine (yet).

A couple of comments about the patch:

1) Firstly, some cosmetic issues - the patch makes a lot of white-space changes to existing files),including adding TAB characters (which aren’t allowed in the Rockbox source). Also, your use of white space isn’t consistent,- e.g. sometimes you use two spaces either side of an ||, and sometimes none.

2) The diff to pcm_playback.c creates a duplicate of what looks like an old (i.e. buggy) version of the WM8975/WM8758 code. This shouldn’t be necessary - you should be able to use (by defining the appropriate macros, or adding a small number of #ifdefs) the existing code without needing to create a copy of it (but I realise the audio driver is still in the early stages).

slimx commented on 2006-02-24 20:31

ok so here is a new patch against current cvs without any TAB char and corrected #ifdefs directives.
it’s done against current cvs and would build cleanly (i’ve tested it in a new fresh cvs directory)

I’ve removed pcm_playback code as Dave have done in current cvs.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing