Rockbox

Tasklist

FS#363 - Recorder - UP button works only 30%

Attached to Project: Rockbox
Opened by Amnon Gebert (amnongebert) - Saturday, 05 October 2002, 19:29 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 11 October 2002, 06:35 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To Linus Nielsen Feltzing (linusnielsen)
Operating System
Severity Low
Priority Normal
Reported Version Release 1.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Archos Jukebox Recorder with 6GB
Model: JBRHD101
Rom version: 1.17i
Rockbox release: 1.3

The UP button works only 30% of the times - the other
70% it dosen't work or acts like Play or FW.
The UP button works 100% Archos official firmwares.
The problem was reported before - on previously
versions (1.0, 1.1 and 1.2) and havn't yet fixed.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 11 October 2002, 06:35 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 07 October 2002, 05:11 GMT

Go to Menu->debug (keep out!)->View I/O ports.

Press F1,F2,F3
and UP and tell me the AN4 readings.
Press LEFT,DOWN,PLAY
and RIGHT and tell me the AN5 readings.

Thank
you,

Linus
Comment by Amnon Gebert (amnongebert) - Monday, 07 October 2002, 23:14 GMT

I tested both AN4 and AN5 for each button and these are the
results:

F1 AN4 187 AN5 000
F2 AN4 255 AN5 000
F3 AN4 3E5 AN5 000

Up: AN4 320 AN5 000 or 187 or 250 depends on
direction of pressure on button

Left AN4 000 AN5 250
Down AN4 000 AN5 3FF
Play AN4 000 AN5 320
Right AN4 000 AN5 187

After testing the quality of the buttons again in the Archos
firmware, I have noticed that when UP is pressed (AN4 must
be 320) it doesn't go right (thus it must ignore AN5 when AN4
is 320). I think this is the correction that should be made.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 08 October 2002, 05:10 GMT

OK, so your Recorder has a button hardware problem. While it certainly
may be possible to filter out key combinations between the keys
mapped to AN4 and AN5, it is not something we want. We depend on
being able to press two or more keys simultaneously (F1+DOWN for
keylock, for example).

Are Up and Play the only buttons that have
this problem on your unit?

/Linus
Comment by Amnon Gebert (amnongebert) - Tuesday, 08 October 2002, 19:03 GMT

using Archos firmware all the buttons work exactly as
advertised. This means that when the UP button is pressed, I
am certain that the Archos firmware disregards AN5. It is
possible to filter out the combination of UP with
Right/Left/Play/Down without filtering out the combinations of
F1/F2/F3 with Right/Left/Play/Down. In any case I don't see
any use for the combination of UP with Right/Left/Play/Down.
You must understand that when I bought my JBR I couldn't
even known of this "hardware problem" because Archos
filtered it out. For all I know this can be a flaw in a whole
series, but an unimpairing one. I think that in this case,
Rockbox should behave in the same way as the original
Archos firmware.

P.S. - Only the UP button has the problem and it is with UP
being UP+LEFT or UP+RIGHT 60% of the time.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 09 October 2002, 05:24 GMT

"using Archos firmware all the buttons work exactly
as
advertised."

Of course. They don't use the key
combinations that we do, and only allows one key at a time. We
do.

"You must understand that when I bought my JBR I
couldn't
even known of this "hardware problem" because
Archos
filtered it out."

Yes I understand that. And you have to
understand that we can't accomodate for all broken jukeboxes out
there.

"I think that in this case,
Rockbox should behave in the
same way as the original
Archos firmware."

I don't. Rockbox
is Rockbox. We have nothing to do with the original firmware.

You
are the only one that have reported this kind of problem.

However, I
will consider including a filter for this, as it is unlikely that we will use key
combinations with up+left and up+right.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 09 October 2002, 09:43 GMT

I have implemented a filter that filters out any combinations of UP and
AN5 keys.

Please test this and see if the problem is
gone.

The fix will be included in the 20021010 daily build. You can
also try the latest bleeding edge build if you are impatient. :-
)

/Linus
Comment by Amnon Gebert (amnongebert) - Wednesday, 09 October 2002, 17:47 GMT

Hi Linus,
the last build works great, the UP button is working 100%.
I understand that the matter is closed and this will stay on
the CVS as it is now.
Thank you very much for the understanding,
The Rockbox firmware rocks!
Amnon Gebert

Loading...