Rockbox

Tasklist

FS#383 - MP3 ends too soon

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 09 October 2002, 23:15 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:39 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Very Low
Priority Low
Reported Version Release 1.3
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

When the battery is less than 3/4 full mp3's stop playing
after about 1:45 of play.

Sometimes dumping to the last directory, sometimes
dumping to the root directory.

I think this is because of a sudden loss of memory.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:39 GMT
Reason for closing:  Works For Me
Comment by Björn Stenberg (zagor) - Friday, 01 November 2002, 16:28 GMT

We need more details? Does it happen all the time? Does it
matter if you charge using Rockbox or Archos? Have you
tried different batteries?
Comment by Blindauer Emmanuel (mooby) - Tuesday, 10 December 2002, 09:31 GMT

Same bug for me.
Having the batterie at 1/4 of the charge, playing a mp3 is
impossible: the play stops after 5/10s.
(1.4 rockbox)
Comment by Blindauer Emmanuel (mooby) - Tuesday, 10 December 2002, 09:39 GMT

oops submit pressed too early.
1.4 rockbox,
archos jukebox 6000
With original mod, no problem.
I use large files sometimes (100Mo+), perhaps it is related
to...
and, another thing: pressing play in these cases, the mp3 is
played a few second, but the display doens't change, i.e. I
don't see the id3 tags scrolling....
Comment by Anonymous Submitter - Sunday, 27 July 2003, 20:50 GMT

My archos jbr20 stops playback under certain circumstances,
too: 1-3 miutes to early, and simplifying my impression: if
rockbox interrupts playback, original firmware 1.28 does not,
and vice versa! . But as far as I can make final judgements, it
seems to me, that it has nothing to do with the state of the
battery. I use the last builds of rockbox and the original
firmware 1.28 and as I said, I notice that both firmwares
behave a little differently: Playback stopps more often using
original firmware. Everytime, when the "breakdown"
happpened, I had observed that the "total time" in wps of
Rockbox hasn't been correct while playback; if the mp3 is
small,e.g. 2:30 min, wps shows total time minus ca. 3
seconds, but no interruption happens (lack/missing time in
total time too small?). At bigger mp3s, e.g. 90 minutes, about
up to 5 minutes are missing in the displayed total time, and
playback stopps, after "playing time" in wps exceeded the
displayed (incorrect) total time by about two minutes.

I have less problems when playing mp3s encoded with
Rockbox itself (difference between real playing time and
displayed total time about 4 seconds when mp3 is half an
hour long, 20 mb big) playback of mp3s made with common
encoders like Lame 3.931 and, even worse, with Musicmatch
(7.5) ON PC the problem is very grave.
It would be really fine, if this bug would be fixed.

I hope my remarks are helpful

Giovanni

my e-mail:
giosecchi@arcor.de

Loading...