Rockbox

Tasklist

FS#440 - Playlist created by MusicMatch don't pla

Attached to Project: Rockbox
Opened by Anonymous Submitter - Tuesday, 15 October 2002, 14:36 GMT
Last edited by Robert E. Hak (adiamas) - Wednesday, 23 October 2002, 02:32 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 1.4
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

First at all I want to congratulate you guys for a great
initiative to fill gaps Archos may never do. Your firware
is far superior and I have the Studio 10 player.

I reported before that playlists weren't working and saw
some related post but your answer is cannot be
replicated. Well, I think I discovered the issue so I may
explain it better for you.

I use MusicMatch to play and store my MP3 music and
therefore I use it for creating the playlists. My music
files are licated within a user directory under Windows
XP. A one entry view of a playlist created by
MusicMatch is as follows:

C:\Documents and Settings\All Users\Documents\My
Music\Kenny G\Going Home.mp3

When playing that playlist, the software try to read but
do nothing else. I then modified the entry to:

\My Music\Kenny G\Going Home.mp3

and it worked. SO apparently, your software is lost
when looking for such long directory structure. I know
there is a work around but I have several playlists and
whenever moving them to Archos I would need to modify
them (no good). The point here is that I don't need to go
for such hassle with the original Archos formware.
Apparently it ignore the initial garbage. Please, don't tell
me I need to go back to original formware. I know this is
an easy issue for you. Please let me know if you may
work with it. Again, origianl firmware reads the playlists
either way.

Regards,
Luis Cajiga
This task depends upon

Closed by  Robert E. Hak (adiamas)
Wednesday, 23 October 2002, 02:32 GMT
Reason for closing:  Invalid
Comment by Daniel Stenberg (bagder) - Tuesday, 15 October 2002, 14:40 GMT

Rockbox requires the file names in a playlist to be correct,
yes. Otherwise it can't find the files.

That's not a bug, that's a design decision. Correct your
playlist accordingly.
Comment by Björn Stenberg (zagor) - Tuesday, 15 October 2002, 14:46 GMT

A suggestion to make it less painful: Use a command like
'SUBST j: "C:\Documents and Settings\All
Users\Documents\My
Music' to create a virtual disk that has the same directory
structure as your Archos. That way, your playlists will always
be correct.

Loading...