FS#444 - Loss of sound and play control.

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 16 October 2002, 09:21 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:20 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 1.4
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


On some occasions, audio output stops. The song is
still playing (minutes and seconds ticking over in the
inteface), and I can use the buttons to browse
directories, change displays etc.
However, I cannot change, stop, or ffwd/rew the current
song in any way. Pause works. If I press ffwd/rew, the
counter moves accordingly but as soon as I release it, it
returns to the previous song position and continues.
(This has happened during normal playback as well.)

The only way to regain control and sound output is to
shut the unit down (holding Off-button) and then turning
it back on. No other problems after the unit is powered
back up.

Frequency of problem is perhaps 1 in every 30 or 40

Using Jukebox Recorder 20.
ROM Firmware is 1.26.
Rockbox version is 1.4.

Reporter is
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:20 GMT
Reason for closing:  Works For Me
Comment by Vincent Kargatis (kargatis) - Wednesday, 16 October 2002, 12:31 GMT

I experienced this several times today using a bleeding edge
build from yesterday (which is why I didn't think much of it). I
also thought it may have been due to pocket jostling, but I
can't be sure. Just wanted to add a 'me too', since the above
a 1.4 report. I've never seen this behavior before, in spite of
using daily builds since 1.3.

Recovery didn't always require reboot, but I could detect no
pattern to it.
Comment by Björn Stenberg (zagor) - Monday, 09 December 2002, 15:50 GMT

This is called "silent play", and we believe it is fixed in the most recent
daily builds.
Comment by Earl (rzrshrp) - Tuesday, 25 March 2003, 00:07 GMT

I'm still having this "silent play problem" with my fm recorder.
I still have usual control though but no sound except for split
seconds about every three minutes or so. I'm using firmware
1.30j and daily build 300324.
Comment by Earl (rzrshrp) - Tuesday, 25 March 2003, 00:13 GMT

Oh, and restarting the player doesn't even work most of the
time. Sometimes if I leave it alone then turn it on, the song'll
play about halfway then go silent. I also have a problem with
the original firmware if that helps any, instead of simply going
silent, it goes silent and fast forwards through tracks so
maybe this is a hardware problem?
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 25 March 2003, 00:32 GMT

If it doesn't even work with the original firmware it is
most likely a hardware problem. You should return the device.
Comment by Anonymous Submitter - Saturday, 17 May 2003, 20:24 GMT

I have the same problem now and then with my Studio 20
with RB 1.4 and 2.0.

Comment by christopher saunders (cis4z) - Thursday, 26 June 2003, 20:34 GMT

I have the same problem happening on my Studio 10, but only
since upgrading to 2.0. Happens daily -- seems to occur
often in response to a tiny little bump on the device.
Comment by Anonymous Submitter - Wednesday, 16 July 2003, 21:39 GMT

I am also having the same problem. I can also contribute that
if you leave the unit alone, after about 2-5 minutes playback

Through this time the HDD light remained on and HDD activity
could be heard if the unit is held close to the ear. Also I think
I can identify a few tracks that are reproducible.
Comment by Anonymous Submitter - Friday, 08 August 2003, 20:18 GMT

Getting the same problem with the most recent build. Can't
determine a common cause.