Rockbox

Tasklist

FS#448 - mp3 play stops mid-song

Attached to Project: Rockbox
Opened by Anonymous Submitter - Thursday, 17 October 2002, 14:52 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 09 March 2005, 10:44 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 1.4
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

With Rockbox 1.4, I have had several instances where an
mp3 stops playing mid-song. It just freezes.

In the most recent occurence, I was playing a playlist
of 1902 files, with shuffle mode on. It stopped midway
through a song. If I hit the play/pause button, the
display would show that it was paused, and if I hit it
again, the play icon would show, though it wouldn't
continue playing.
When I powered the unit down and restarted and resumed
playing, it began playing in the middle of the song
before on the playlist, not the song it got stuck on.
I went and selected the song it got stuck on, and it
played fine.
I used Rockbox 1.3 quite a bit, and never had any problems.

Here's info about my machine:
Archos Jukebox Player 20
RockBox 1.4
rom 5.06
Battery: 74%

Unfortunately, I don't have the model number as I don't
have the unit handy.

Feel free to email me if you need anything else!

jeffn@zombieworld.com
This task depends upon

Closed by  Daniel Stenberg (bagder)
Wednesday, 09 March 2005, 10:44 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Logged In: YES
user_id=1110

This report is very old and concerns a Rockbox version from eons ago.

Lots happen in the Rockbox all the time, and if you still have
problems with this matter I suggest you file a new entry.
Comment by Anonymous Submitter - Friday, 18 October 2002, 16:38 GMT

I have the same problem too!
But I already had it with Rockbox 1.3 (the first Rockbox
version I used). I even reported the bug and zagor or someone
else said that it was fixed in CVS.
But now I've got the same problem again with Rockbox 1.4

In case of vibration (when I got my player in the bag of my
trousers), the song ended in the middle and the Firmware
crashed, red light on...etc. (same behaviour as
jeffn@zombieworld.com described - with pause and play
symbol etc...). I had to restart the player.

The next time the unit didn't crash, but it simply skipped to
the next song.

The problem is that the unit can't access the HD in case of
vibration. The Archos Firmware used to do this too, but it
didn't crash. The Archos Firmware used to just freeze or hang
until the unit was held still (no more vibration). Then it
accessed the HD and continued playing.

I've got: Archos Jukebox 6000, HW-Version 5.02
Rockbox 1.4 release (not the daily builds)
/Archos Firmware 5.07a
Comment by Linus Nielsen Feltzing (linusnielsen) - Saturday, 19 October 2002, 07:16 GMT

The reason we said that this is fixed in CVS is because we have written
doce that is supposed to handle the case when the hard disk reads fail.
This may not work as expected, though, so we obviously need to look
more into this.
Comment by Anonymous Submitter - Thursday, 24 October 2002, 20:03 GMT

I have had this exact problem too.

If you want a theory, I think it has to do with skip
protection. The reason I say this is because it has only
happened to me when I've been walking. I haven't ever had it
happen when the player was motionless.

My machine:
Archos Jukebox Recorder 20
Rockbox 1.4
Comment by Anonymous Submitter - Monday, 28 October 2002, 15:29 GMT

I don't think that my problems were due to vibrations.
Often, when it would stop, the unit was stationary-- plugged
into my home stereo. And as I said, I never had this
problem with 1.3.
Using a recent daily build seems to fix the problem, though.
Comment by Anonymous Submitter - Thursday, 05 December 2002, 10:07 GMT

Yep, this happened to me to...
I was also in shuffle mode(!), when I pressed pause, the
archos paused and never treturned to life no matter what button
I pushed.... (till I pushed OFF).

I'm using Archos Recorder 20 with the build Rockbox
CSV-021204
Altough I am using the rockbox only for a few days, I can
tell that this never happened when I was in regular playing mode,
only in shuffle mode.
Comment by Anonymous Submitter - Saturday, 07 December 2002, 02:38 GMT

new guy here with same exact problem...it occurs when it is
time for it to read the next 'chunk' into memory from the disk i
believe and it happens more often than not (ver 1.4) making it
really worthless for me to load rockbox.

Symptom: turn on unit, pick a folder/song, hit play. Plays for
about 2MB, then no HD access light, just locks up. If you wait
long enough it usually begins PLAYING the next song, but
continues displaying the last song. Random amount of
shutting off/on will get it working again, usually can't play
anything for a good 10 minutes of this. Screaming, cursing,
hand gestures seem to help.

I'm back to hardware firmware til this gets addressed. post
up any tests you'd like us to do.

thanks & keep up the good work, this will be a great product!!
Comment by Anonymous Submitter - Saturday, 07 December 2002, 03:05 GMT

Pry off the battery covers and put in that second set of
batteries Archos sent you for the unit, the green meanies.

I think you have a dead cell and when the disk drive comes
on it pulses the dead battery enough to drive the hardware
crazy past its capacity to tolerate the voltage dip.

If there's a bad cell, the unit will run fine....but the bad cell
causes the voltage to start to drop too fast.

Put the cells in and charge it until it says CHARGED. See if
it does the same thing. If you don't have the batteries,
there are great 1700 to 1800 maH Nickel-Metal Hydrides
now for sale at Circuit City, Best Buy and even Ratshack....

Larry
Comment by Vincent Kargatis (kargatis) - Wednesday, 29 January 2003, 11:41 GMT

This occurs to me with at least recent daily builds (2002 Nov
onwards, maybe well before) in a single identifiable
circumstance - when the VBR header is bad (lacking the xing
(?) header, whatever, can't remember the exact issue). The
song starts, but next buffer read it goes silent.

An example file is at:
http://kargatron.net/mp3/badHeader.mp3
Comment by Björn Stenberg (zagor) - Thursday, 30 January 2003, 13:12 GMT

The badHeader.mp3 file bugs because it's horribly corrupt. The Xing
header claims the file contains 0 mp3 frames. (No, it's not missing. It
explicitly says "framecount: 0".)

Maybe we should try to work
around this somehow, since it appears many people use buggy
encoders (or, many encoders are buggy). This is probably the remaining
reason for "silent play" behaviour.
Comment by Vincent Kargatis (kargatis) - Friday, 31 January 2003, 13:18 GMT

Windows users experiencing this bug - try VBRfix on these
files - it does correct the issue with my bad files mentioned in
the previous note.

http://www.willwap.co.uk/Programs/vbrfix.html

I'm not sure if an equivalent program exists for unix. It's
pretty painless to use if you set the right options - just
choose the directory and overwrite the old files with updated
ones (that rockbox likes).
Comment by Anonymous Submitter - Thursday, 15 May 2003, 20:22 GMT

I'm having this problem as well with version 2.0, and it happens all
the time (at least every other file). Obviously, this is something
serious that prevents the use of the machine.

This happens even when the unit is sitting still and hooked up to
my home stereo. It also happens whether or not shuffle is on or
off.

Archos Juke box Recorder 20

Thanks,
Jeff Myers jmyers@goucher.edu
Comment by Anonymous Submitter - Wednesday, 04 June 2003, 02:27 GMT

I had this same problem with my Studio 20, running the
latest build. I've even tried "upgrading" to the
bleeding-edge daily builds several times to no avail.

Curious: Would it getting unplugged without disconnecting
from the software first cause files to get corrupted, even
if they weren't open at the time?
Comment by Anonymous Submitter - Friday, 27 June 2003, 05:23 GMT

I was having this problem with the last version (I'm sorry, I
belive 1.4). Five days ago I downloaded version 2.0, and
today it started again. I listen mostly to playlists of 200-300
songs, and sometimes the song stops playing, although the
second/minute counter continues. The only thing that cures
this is to turn the machine off, and then on again. Usually if
this happens once, it will happen several times again. This
really seems unacceptable, and I'm wondering if anyone has
updated insight to the problem.

Other descriptions:

Unit: Archos Recorder 15

Received as a gift on December 25, 2002 - first used it about
one week afterwards.

Batteries have not been changed since, and I usually
recharge the unit overnight, nightly.

For the past six months I have used the recorder mostly
every weekday for about 90 minutes. Also, I download music
for about 2 hours/night once or twice/week.

From what I remember, the device has not stopped while
hooked up to my stereo, and this has never happened while
connected to the USB.

Please, if anyone has any thoughts or ideas, let me know. I
like this product a lot, but if this continues, I may be forced
to go I-Pod.

Regards,

Todd Lang

tlang@dc-intl.com
Comment by Anonymous Submitter - Sunday, 29 June 2003, 00:34 GMT

I have the same problem. I have a AJBrec 20 running
ROCKBOX v2.0. After about 2 hours the the problem starts -
stops playing with counter still counting. Doest seem to
happen with a fully charged battery. My unit starts having
problems areoun 40%-60% charge. I changed the batteries
to a fully charged set of Energizer 1850s. The player lasted
about 2.5 - 3 hours and the problem reappeared. Seems to
have something to do with low power. Sometimes the red HD
light stays on and I here the HD clicking but no music.

My player is only 3 days old. I keep hearing people getting 6-
8 hours of play time. I can bearly get 2 1/2. Most of my
MP3s are 160kHz.
Comment by Bruce Hoye (homerdog) - Sunday, 29 June 2003, 22:03 GMT

I entered the update on 2003-06-28 (I desided to register).
I have another update. I upgraded my AJBREC 20 to the
latest daily build (2003-06-28 at the time). I started
listening to music. The recorder was 100% charged and had
been plugged in at least 12 hours. The batteries being used
are energizer 1850 nimh which have been charged at least
three times and have worked fine in other devices. I set the
Battery Capacity in RockBox to 1850. The recorder stopped
playing 2 hours and 7 minutes later. The charge level,
according to the recorder, was 54%. The song stopped in
the first minute or so of the song. The counter was
continuing to count. In previous times, the song may start
back up and play for a few seconds before going silent
again. I am using shuffle play so it happens on random
songs - not the same song. I turned off the recorder and
tried to power it back on but all I got was a clicking noise (HD
I presume) and a frozen boot up screen. I plugged in the
power adapter and it booted.
Comment by Anonymous Submitter - Friday, 11 July 2003, 14:02 GMT

I have experienced the same problems with the player (FM
Recorder 20G) stopping mid-song and going silent even when
the player shows that the song is still playing. It occurs
randomly. I was using Archos 1.30j firmware when the
problem first appeared.

I upgraded to Rockbox to see if it would fix it but it didn't. I
contacted Archos tech support and they tell me that the unit
is defective and must be repaired.
Comment by Anonymous Submitter - Friday, 25 July 2003, 23:04 GMT

Random freezes have been a problem for me only when I'm in
my vehicle. Using a AJBrec 20 with Rockbox 2.0 and in the
vehicle it is pluged into the stereo via a cassette adaptor.
About an hour down the road the JB will freeze mid-song with
the red light on steady. Can only resume by shutting off and
restarting. Once it happens it seems to be an on-going
problem. Doesn't matter if I'm using a playlist or not. At
home I can start the damned thing and it works perfectly.
One other difference between home use and vehicle use is
that I tend to run the JB for longer continuous times than
at home. At home, max continuous time is usually half an
hour or so. I'm thinking the problem is related either to
bumpy roads or time in use.
Comment by Anonymous Submitter - Tuesday, 12 August 2003, 02:21 GMT

I've had the same problem.
Comment by Bruce Hoye (homerdog) - Wednesday, 20 August 2003, 21:28 GMT

An Update that may help:

I contacted Archos via e-mail and explained my problem.
They immediately provided me with an RMA number. I sent
it in and received it about 14 days later. After an overnight
charge I have experienced an 8 hour playtime (it's still
playing!). Before getting fixed it only lasted 2 hours.

I suggest that if you are experiencing this problem that you
contact Archos and have them fix the problem. I'm glad I
did.
Comment by Anonymous Submitter - Wednesday, 27 August 2003, 04:35 GMT

Is there a solution to this problem?

I have it too...once every five songs or so (there's no definite
pattern, it just seems to happen often) no sound is emitted
from the Rockbox, the red access light stays on, but the
display screen still shows that the song is continuing to play.

Is there a solution for this? Do I have to send the unit back
to Archos or is this a Rockbox problem?

I have version 2.0 on a fully loaded Recorder 20.

Please email any suggestions: musical60@hotmail.com
Comment by Mike Holden (mikeholden) - Wednesday, 27 August 2003, 08:13 GMT

I'm sure there has been further work on this since v2.0 was
released.

Before submitting bug reports, you should always check that
the bug still exists in the latest daily build, which you can
download from the website.

Please try a daily build and see if the problem still exists.
Comment by Anonymous Submitter - Saturday, 27 September 2003, 16:07 GMT

Hello, I'm having this same issue with a jukebox studio 20,
60gb hardrive upgrade, archos firmware rom 5.08, and I am
using rockbox version 2.0, my directory has 849 songs,
battery power 74%, the freeze happens randomly, and it may
play 10 songs fine but freeze midway on song 11. My email
address is geminipanther@excite.com. Please let me know if
there is a definite fix for this as I love the rockbox and I even
had this problem before the 60gb hardrive upgrade when I
was using the original 20GB hardrive.
Comment by Bruce Hoye (homerdog) - Saturday, 27 September 2003, 16:34 GMT

Since Archos fixed my Archos Jukebox Recorder 20 back in
early August, I have not had any problems. I have used it
nearly everyday at work where is was on continuosly for at
least 9 hours. The unit would continue playing even thugh
the battery level was in the 3%-5% range.

All you who are having this problem - it is not a RockBox
problem, it is a hardware problem and should be returned to
Archos so they can fix it.
Comment by Anonymous Submitter - Saturday, 27 September 2003, 17:39 GMT

I don't believe it is a hardware problem since when using the
plain archos firmware (not rockbox) this never happened, not
once. Only after I started using rockbox version 2.0.


Hello, I'm having this same issue with a jukebox studio 20,
60gb hardrive upgrade, archos firmware rom 5.08, and I am
using rockbox version 2.0, my directory has 849 songs,
battery power 74%, the freeze happens randomly, and it may
play 10 songs fine but freeze midway on song 11. My email
address is geminipanther@excite.com. Please let me know if
there is a definite fix for this as I love the rockbox and I
even
had this problem before the 60gb hardrive upgrade when I
was using the original 20GB hardrive.
Comment by Anonymous Submitter - Saturday, 27 September 2003, 17:43 GMT

I don't believe it is a hardware problem as this does not
happen when using only the archos firmware (not rockbox).
This happened when I first started using rockbox version 2.0.

Hello, I'm having this same issue with a jukebox studio 20,
60gb hardrive upgrade, archos firmware rom 5.08, and I am
using rockbox version 2.0, my directory has 849 songs,
battery power 74%, the freeze happens randomly, and it may
play 10 songs fine but freeze midway on song 11. My email
address is geminipanther@excite.com. Please let me know if
there is a definite fix for this as I love the rockbox and I
even
had this problem before the 60gb hardrive upgrade when I
was using the original 20GB hardrive.
Comment by Anonymous Submitter - Wednesday, 10 March 2004, 06:09 GMT

Same exact problem here...using a Studio 20
Comment by Anonymous Submitter - Friday, 12 March 2004, 15:15 GMT

I have the same problem using rockbox v2.1
BUT!!!
When playback freezes and you let it sit for a couple of
minutes, playback suddenly continues. Until it freezes again
some tracks later.

For me it looks like some buffer underrun problem, as
rockbox somehow forgets to fill up the buffer before it's
empty. Then for a couple of minutes nothing happens. It
looks like it's freezed, and only shutting down the player
helps. But suddenly the harddisk spins up, rockbox fills the
buffer and continue with playback at exactly the same
position where it stopped.
Comment by Anonymous Submitter - Tuesday, 23 March 2004, 07:34 GMT

I have the same problem on my new Archos 20gb Jukebox
Recorder Special Edition (V2). I'm using Rockbox v2.2 (not
flash-rom version)
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 23 March 2004, 07:39 GMT

I'd like you to try the latest daily build to see if there's
any improvement.
Comment by Anonymous Submitter - Saturday, 24 April 2004, 11:15 GMT

i have the same problem with my jukebox recorder V2, arcos
ROM 1.40a. im using rockbox v2.2, the daily buid of 23.04.
2004.
apart from that: great job!
Comment by egilskaljo (egilskaljo) - Monday, 19 July 2004, 09:10 GMT

Just downloaded the July 18th, 2004 daily build and am still
experiencing this problem. Same as described above.

The problem is most severe when I go running with my mp3
player - now it freezes once every song. It seems to be even
more severe than before - as I had the same problem with
the Archos firmware, but it wasn't as bad. This problem
happens with both playlists (doesn't matter if shuffle is on or
off) as well as regular playing.

Here is (hopefully) all the relevant info

Archos Jukebox Recorder 20
Rockbox Ver CVS-040718
Rockbox Info:
Buffer 1.596 MB
Disk 18.60 GB
Free 0.1 GB (the drive has about 60-70 MB free on it)

mp3s were encoded with Simple MP3 maker. I also connect
my mp3 player to a computer running windows 2000.

please let me know what else might be needed!
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 19 July 2004, 09:41 GMT

The thing is this: hard disks are sensitive to vibration and
shock. We may be able to make it better, but we will never
get rid of this problem. Hard disk based players are just
not made for running.
Comment by Anonymous Submitter - Monday, 19 July 2004, 09:56 GMT

Thanks for the quick reply!

I understand that - but it really does seem like the problem
has gotten worse with the latest versions of Rockbox.

I had the same problem with the archos firmware and an
earlier version of Rockbox (2.1, I think) - there it was not as
bad (it would freeze maybe every four or five songs,
sometimes it wouldn't freeze at all). Now it freezes just about
every song. Of interest - if, after restart, I select 'resume', it
will freeze almost immediately.

If it would be at all possible to make this 'better' then that
would be most appreciated!

Thanks again!
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 19 July 2004, 10:14 GMT

Interesting. Can you go to the Disk Info debug page and tell
me the information of your hard drive?
Comment by egilskaljo (egilskaljo) - Monday, 19 July 2004, 10:22 GMT

Under Disk Info, all it says is

Model
HITACHI_DK23DA-20
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 19 July 2004, 10:36 GMT

I'd like you to try a test version of today's daily build
and see if it gets any better:

http://linus.haxx.se/egilskaljo_test.zip

This version disables the assembler optimizations of the
hard drive read/write routines.
Comment by egilskaljo (egilskaljo) - Tuesday, 20 July 2004, 09:13 GMT

ok so I installed version 040719-1231 and went for a run this
morning and am happy to say that the player did not freeze
even once! (almost 40 minutes)

so this looks good - I'll keep this version installed and I will
see if the problem returns.

Let me know if there is any other info you need, or any
further tests I should run.

Thanks again!
Comment by egilskaljo (egilskaljo) - Sunday, 19 September 2004, 18:21 GMT

just a brief followup on this one - most of the time, the player
works fine.

however, it still does freeze from time to time. sometimes (not
always though) the player will resume playing, in about 5
minutes or so.

also worth noting - if it does freeze, then it will repeatedly
freeze - even after turning the unit off and on. as I
mentioned before, if I do a resume after a restart, it will
freeze almost immediately.

another interesting thing - not sure if it has anything to do
with this - the unit says it has 0.0 gb free - when it has
about 200 mb free or so. when the regular archos firmware is
installed it says the same thing. not sure why it thinks it has
no hard drive space left.
Comment by egilskaljo (egilskaljo) - Sunday, 19 September 2004, 18:26 GMT

just a brief followup on this one - most of the time, the player
works fine.

however, it still does freeze from time to time. sometimes (not
always though) the player will resume playing, in about 5
minutes or so.

also worth noting - if it does freeze, then it will repeatedly
freeze - even after turning the unit off and on. as I
mentioned before, if I do a resume after a restart, it will
freeze almost immediately.

another interesting thing - not sure if it has anything to do
with this - the unit says it has 0.0 gb free - when it has
about 200 mb free or so. when the regular archos firmware is
installed it says the same thing. not sure why it thinks it has
no hard drive space left.
Comment by Daniel Stenberg (bagder) - Wednesday, 09 March 2005, 10:44 GMT

This report is very old and concerns a Rockbox version from eons ago.

Lots happen in the Rockbox all the time, and if you still have
problems with this matter I suggest you file a new entry.

Loading...