FS#464 - song plays 2 times without repeat "one"

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 23 October 2002, 23:22 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Monday, 11 November 2002, 22:23 GMT
Task Type Bugs
Status Closed
Assigned To Linus Nielsen Feltzing (linusnielsen)
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


i use daily build 2002/10/22, today i realized it 2 times, that a song
was repeated without repeat setting to "one". this happened also
with daily builds earlier than 10/22.

hardware: ajb6000
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Monday, 11 November 2002, 22:23 GMT
Reason for closing:  Works For Me
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 28 October 2002, 23:03 GMT

Please explain a little more what you mean.
Comment by Anonymous Submitter - Tuesday, 29 October 2002, 15:55 GMT

ok, lets try ;)
i have a playlist file called all.m3u this is created by

dir /b /s /ON *.mp3 >all.m3u
from the root dir of my

now when i'm playing this playlist, it sometimes happens that
an entry on this playlist is played 2 times, instead of going to the next file in
the playlist.
and my repeat setting is set to "repeat all".
is use
daily build of octobre 22nd and have a jb 6000 with rom firmware
maybe rockboxx doesnt follow the playlist. this evening i will
test if a song is even played more than a second time...
hope this
description helps more than the previous.
btw i cant reproduce when
this happens, i just realized THAT it happens...
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 29 October 2002, 21:50 GMT

That sounds really weird. And you are absolutely sure that
you have no duplicate songs in your directory tree?
Comment by Andreas (crash80) - Wednesday, 30 October 2002, 00:11 GMT

i'm sure. there are some exceptions, but the songs which were repeated
dont have any duplicates in the playlist.

as i said i tried this
evening to reproduce, but it didnt happen so i cant say for example if this
happens at the same tracknumber or so...
i'll continue bugreport if it
happens again
Comment by Andreas (crash80) - Monday, 11 November 2002, 13:08 GMT

i recently tried to reproduce, but didnt have success. so no work for you ;-
think you can close this bug report