Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Bootloader
  • Assigned To No-one
  • Operating System Iriver H300 series
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Version 3.1
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Rui Marinho - 2006-02-28
Last edited by Willliam W - 2019-08-04

FS#4753 - H300 USB Bootloader Mode not working properly

I haven’t been able to successfully connect my iriver h340 via USB, using the bootloader USB mode, even after numerous connect/disconnects. Windows XP won’t recognize anything. USB Mode works good after booting rockbox.

Closed by  Willliam W
2019-08-04 19:06
Reason for closing:  Out of Date
Steve Bavin commented on 2006-04-07 15:58

I’m seeing the same thing.

I’ve performed some checks by using a USB monitor program - http://www.hhdsoftware.com/usbmon.html which allows trial runs for
this shows nothing happening at all from the PC end when using the bootloader USB mode.

As a comparison, if I boot Rockbox first, the logged data starts with the
Get Status Request (DOWN), 07.04.2006 12:59:41.2451792
status from Device. Data length 0×2 bytes (00
Control Transfer (UP), 07.04.2006 12:59:41.2451792
Handle: 0x85a0a9f4

03 00                                             ..

Setup Packet 80 00 00 00 00 00 02 00€....... Recipient: Device Request Type: Standard Direction: Device→Host Request: 0×0 (GET_STATUS) Value: 0×0 Index: 0×0 Length:
(This then succeeds every time.)

I’ve now tried this on 3 different PCs - two running Windows XP SP2 and one running Windows 2000 SP4 - and all 3 machines give exactly the same results. In the unlikely case it’s relevant, my Iriver firmware is 1.28E.

James Teh commented on 2006-04-09 14:29

I have the same problem, although the bootloader USB mode *sometimes* works for me. Unfortunately, I haven’t been able to determine any difference in circumstances between the occasions when it works and those when it doesn’t.

Matthias Mohr (aka Massa) commented on 2006-04-27 16:35

Strange - USB bootloader (with v5) works perfect for me (H340).

Can anybody give some more details???

Steve Bavin commented on 2006-04-28 12:10

Not much to it - method is as
H340 is powered off and no charger is
Connect USB cable to USB 2.0 DEVICE
H340 powers up, displays “Rochbox Bootloader/Version 5/Batt: ?.??V” - then “Bootloader USB
PC does not recognise anything
I boot into the IRiver firmware (1.28E), USB works fine every time.

Matthias Mohr (aka Massa) commented on 2006-04-30 09:30

Sorry, it works perfect here (with Win2000-SP4 and with
somebody else able to reproduce this behaviour?

James Teh commented on 2006-04-30 12:19

For me, the bootloader USB mode sometimes works and sometimes doesn’t. When it doesn’t, symptoms and steps to reproduce are exactly the same as above; unfortunately, i haven’t been able to determine any difference in circumstances between the failures and the successes. Bootloader v5, firmware 1.29K.

Peter D'Hoye commented on 2006-05-01 14:07

Please add following detail: how are you
USB direct on
powered
unpowered
usb 1.1 or 2.0

I’ve seen it do strange things on disconnect when using the hub of a DELL monitor.

It is maybe also related to a setting in retailos about connecting on desktop or
can also try enabling/disabling usb charging in retailos

Steve Bavin commented on 2006-05-02 07:07

USB direct to motherboard on 3 different PC with different chipsets. No hubs involved at all. RetailOS works reliably on all 3
Charging in RetailOS was disabled, but enabling it makes no difference to Rockbox. USB Conn Mode in RetailOS was set to Desktop, tried Hub, but no change.

Rui Marinho commented on 2006-05-03 21:35

I used USB direct to motherboard, on Windows XP SP2, USB 2.0. Sometimes works, sometimes doesn’t...any idea on how to debug it locally?

James Teh commented on 2006-05-04 03:16

As noted above, the bootloader USB mode occasionally works for me but often fails. I have tried it with USB 2.0 direct to motherboard on several machines running Windows XP SP2 and also tried it with USB 1.1 direct to motherboard on a Linux kernel 2.6.14.3 system. Under Linux, nothing in lsusb -v changed and nothing was reported in the kernel logs.

Alexander Spyridakis commented on 2006-05-08 21:16

I can confirm that I have seen more than 2 H300s not to be able to get recognised by Windows XP (and Ubunutu)(haven’t tested other
seems that this bootloader bug affects some H300 users. With or without a HUB I get the same
is a whole thread for it in MisticRiver forums.

It would be good to know what Linus has to say about this, since he wrote the Bootloader.

Peter D'Hoye commented on 2006-05-17 12:35

There is also another issue, maybe related to this one:

When disconnecting from my dell monitor at work, the h340 stays in usb mode.

This depends on the usb settings of the original firmware (don’t remember which
I can solve it that way.

Fredrik Öhrn commented on 2006-05-31 15:07

For what its worth, on my new computer with a nForce 4 chipset and USB 2.0 ports bootloader USB mode works perfectly every
my old box with a nondescript VIA chipset and USB 1.1 ports it normally doesn’t work, but given enough patience and restarts of the player it will
Rockbox is up and running USB mode always works fine with both PCs. Both PCs run Windows XP and I have never touched any USB related settings in Windows.

Jerome Vizcaino commented on 2006-06-05 10:04

Hi,

I’ve been experiencing problems with the USB bootloader
running a recent Debian Linux, kernel 2.6.16.18. USB is built in and uses USB
own an iRiver H320 with a V5 bootloader and 1.30 EU firmware
Rockbox is loaded, USB works very
is what’s printed in the syslog.

Jun 5 12:00:13 localhost kernel: usb 1-2: new high speed USB device using ehci_hcd and address
5 12:00:14 localhost kernel: usb 1-2: configuration #2 chosen from 1
5 12:00:14 localhost kernel: scsi24 : SCSI emulation for USB Mass Storage
5 12:00:14 localhost kernel: usb-storage: device found at
5 12:00:14 localhost kernel: usb-storage: waiting for device to settle before
5 12:00:19 localhost kernel: Vendor: TOSHIBA Model: MK2004GAL Rev:
5 12:00:19 localhost kernel: Type: Direct-Access ANSI SCSI revision:
5 12:00:19 localhost kernel: SCSI device sdb: 39063024 512-byte hdwr sectors (20000
5 12:00:19 localhost kernel: sdb: Write Protect is
5 12:00:19 localhost kernel: sdb: Mode Sense: 00 4a 00
5 12:00:19 localhost kernel: sdb: assuming drive cache: write
5 12:00:19 localhost kernel: SCSI device sdb: 39063024 512-byte hdwr sectors (20000
5 12:00:19 localhost kernel: sdb: Write Protect is
5 12:00:19 localhost kernel: sdb: Mode Sense: 00 4a 00
5 12:00:19 localhost kernel: sdb: assuming drive cache: write
5 12:00:19 localhost kernel: sdb:
5 12:00:19 localhost kernel: sd 24:0:0:0: Attached scsi disk
5 12:00:19 localhost kernel: usb-storage: device scan
5 12:00:21 localhost kernel: UDF-fs: No VRS
5 12:00:21 localhost kernel: UDF-fs: No VRS
5 12:00:21 localhost kernel: Unable to identify CD-ROM
5 12:00:21 localhost kernel: Unable to identify CD-ROM
5 12:00:21 localhost kernel: FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!

Then my H300 icon pops up on my KDE desktop and device is mounted perfectly.

Now, when using the USB bootloader (iRiver is off, no prower cable, then USB is plugged in) nothing gets
chipset is an ICH5 and works perfectly under Linux.

Hope that helps.

Adam commented on 2006-10-13 07:36

I’m getting the same problems as mentioned
(motherboard), XP SP2.

Adam commented on 2006-10-13 08:15

Bootloader USB works for me if I select the “Hub” option in the original firmware, and not if “Desktop” is selected.

Alexander Spyridakis commented on 2006-10-13 16:09

I wish that would be the case, but for me it will refuse to work even when in original firmware I select the Hub
I am not sure how this can have any relation to USB bootloader on rockbox, in any case more people should test these options just to be sure.

Jerome Vizcaino commented on 2006-10-14 13:41

I’ve tried setting up the hub mode instead of desktop mode for USB. USB bootloader still doesn’t
I’m a bit sceptical about that ‘hub mode’ trick.... how could the iRiver original mode affect the Rockbox bootloader when there’s a power off between the two things ?

Tobias Langhoff commented on 2006-11-16 21:55

Same problem here. The USB connection works perfectly in both the iriver firmware and Rockbox, but not in the bootloader. I use GNU/Linux, and nothing is printed in dmesg here either, just like in the above comment by Jerome. Motherboard USB 1.1.

Víctor Zabalza commented on 2006-12-12 22:43

It doesn’t work at all for me either.

Using a h340 with v5 bootloader on usb2.0 connection (via chipset) to a gentoo box with kernels from 2.6.12ish to 2.6.19.

I’ve repeatedly checked the kernel logs from time to time and it never shows anything.

Steve Bavin commented on 2007-03-02 14:10

The updated H300 bootloader now in SVN resolves this issue for me.

Alexander Spyridakis commented on 2007-03-02 15:17

Yes, the new bootloader fixes this problem for me too.

I will leave this task open until the final bootloader is released and more people would be able to verify it.

Peter D'Hoye commented on 2007-05-27 18:26

The latest h3x0 bootloader in svn doesn’t boot my unit 50% of the time! The last thing it prints it the battery voltage. I get the feeling that disk spins up a bit earlier or later, so it may be related to the fact that I’ve got an 80GB disk installed (MK8007GAH)

Steve Bavin commented on 2008-10-17 12:35

Current SVN bootloader works for my H300+MK8007GAH.

However it fails to boot for petur’s H300+MK8007GAH - crash appears to be in thread.c.

I’d guess that the change which broke it is r12514 or r12519 - maybe look at http://svn.rockbox.org/viewvc.cgi/trunk/bootloader/main.c?r1=12513;r2=12519;pathrev=12519

Matthias Mohr (aka Massa) commented on 2009-09-24 11:10

with the SVN bootloader I have another effect which vanishes when using the official v5
sucks my batteries empty, so it seems the USB loading does not work the same as before...

I noticed this because my batteries are not the best anymore and therefore needs to be loaded more often than
plug in my H340 in my car which actually loads it via
with the now no longer perfectly working battery it’s not able to load it completely - after a while in the car I have to put it out and fully load it with the power supply unit.

When using it with v5 bootloader I need to do it after about one or two weeks “normal” driving (every workday to work an
using it with the SVN bootloader I need to do it after about two days!

BTW, will there ever be a newer released H3x0
some developer still working on it?

Matthias Mohr (aka Massa) commented on 2009-09-24 11:12

soirry for my bad English - replace “load” in my above comment with

Steve Bavin commented on 2009-09-24 11:14

If I understand correctly, neither the v5 or SVN bootloaders support charging in USB bootloader mode. It may be that the SVN bootloader draws more current (e.g. has the backlight on, or keeps the disk spinning). It would be useful if you could look for visible differences like that and report back.

Matthias Mohr (aka Massa) commented on 2009-11-19 11:20

pondlife: Sorry that I answer so late - I forgot to look at this again (and did not get any mail from flyspray about your answer...)

I’m pretty sure that both v5 and SVN bootloaders do charge my device in USB bootloader
my old accu would have been drained empty much earlier...

I’ll compile a new SVN bootloader and test the behaviour - especially for disk spinning and
then I’ll report
it may last at least a week or so)

Steve Bavin commented on 2009-11-19 11:25

IIUC, both bootloaders charge, but at 100mA, not 500mA. With SVN , the backlight is always on and I think the disk stays powered, so there’s definitely room for improvement. (Not sure about v5 though!)

Matthias Mohr (aka Massa) commented on 2009-11-19 12:19

Could we make the bootloader charge at
also respect the ““Charge during USB connection” setting (which it IMHO can not do
bootloader can only access NVRAM, correct? So we’d have to add a corresponding NVRAM flag for this?

About backlight and disk: I’ll have a look at it (differences between v5 and trunk)!

BTW, does a SVN revision tag for the v5 exist?

Carlo Castillo commented on 2011-09-06 07:40

Unsure if anyone has noticed this. Came across this bug while reading the release notes. I own an H340 but have never experienced this. However, I noticed so far from the messages that those who have the European fw 1.29E have this problem, while those with Korean fw 1.29K do not. Looking at my device, I have 1.29K as well. Just mentioning this on the off-chance that it may help.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing