Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System Iriver H300 series
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Anonymous Submitter - 2006-03-01
Last edited by bagder - 2006-03-01

FS#4757 - OldSchoolNeo.wps freezes the H300

After loading OldSchoolNeo theme from RockBoxH300Optimized-200602281100-v0.63.zip, if I go to the WPS and try to play a file, either the H300 freezes, or worse shutdown (I only tried twice :) ).
When it shutdown, I had no mean to restart it for a while. The disc was stopped and the start button didn't work. I tried several key combinations without result. Finaly, I managed to restart by pushing the reset button (near the MIC) several times.

Closed by  christi-s
2006-03-19 12:06
Reason for closing:  Invalid
Additional comments about closing:  

H300 experimental build is not supported.

Project Manager

1. Does this bug happen in a plain normal Rockbox build?

2. If so, can you please provide the WPS you use to make the problem happen?

Does this bug happen in a plain normal Rockbox build?
Yes, I just installed this build and it happened while I was testing each theme.
If so, can you please provide the WPS you use to make the problem happen?
The WPS is the one included in the build.
I join the files extracted from the package.

Optimized is NOT an official Rockbox build. Does the freeze happen in a build downloaded from Rockbox.org, or have you ONLY tried Optimized?

It only happened with optimized.
Sorry, I'm a newbie.
I don't know the relations between needleboy from the misticriver forum and the rockbox team. But I think, as he put a release "(…)every time a change will be made in the CVS that regards us, H300 users(…)" on the misticriver forum (Cf. http://www.misticriver.net/showthread.php?t=35654), that many people shall install these releases and hence be exposed to their bugs.

I installed the build CVS060301 I got this morning at http://www.rockbox.org/daily/h300/rockbox-h300-20060301.zip and the same problem occurs if I load the theme Arctic_Desert this time. When I try to play a track, the screen is correctly displayed but the track is not played, the screen is frozen, the buttons have not effect and I have to reset the H300 with a pin to turn it off.

Project Manager

And can you please attach a version of this "Arctic_Desert" too please? It is not bundled in any official Rockbox release.

Here it is.
But is it still risky to build elaborated themes for the WPS ?

Well, I notice that it looks like there are some % tokens in that WPS that are patch-dependent, so if I'm right that they're not part of the official build, that WPS requires the Optimized build to run anyway.

Project Manager

I don't have a h300 but I could load this WPS and use it fine in my h300 simulator build.

I believe it uses a %c tag that Rockbox doesn't support, but apart from that it looked fine to me.

Could you show me where is the error to make a test with a correct file ?

Project Manager

Check for the %c tag in the WPS file.

*But* the WPS should of course not cause any freezing even if it contains unsupported tags.

Same problem without the %c.
I'll try to build a simulator tomorrow and simplify the .wps file to see where the problem comes from.

I can suppress the problem if I comment the last lines of the file :

#%?lh<%xdz%xdn>

#%?mp<%xdp%xdn|%xdy%xdm|%xdp%xdn|%xdy%xdk|%xdy%xdl>

#%?bp<%xdj|%?bl<|%xda|%xdb|%xdc|%xdd|»

#%?pv<%xdA|%xdB|%xdC|%xdD|%xdE|%xdF|%xdG|%xdH|%xdI|%xdK|%xdJ>

If I uncomment only one of these line, the problem occurs.
Some syntax errors (one | and one > additionals) and one tag (%xdn) referring to an undeclared preloaded image seems to have no effect on the problem.

I'm still new to WPS, but they all seem to have some errors:

1) No seperating |
2) Last seperating | missing
3) Too many |'s (<| … |>)
4) Presumably '%xdl' should be '%xdL'?

As I'm experimenting with my own WPS, I'm also finding that various errors cause lockups, which is frustrating.

ignore 4), the font make it look like a lower-case l. I can't immediately see a problem with this line, perhaps the bitmaps it uses aren't declared properly.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing