Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System All players
  • Severity Very Low
  • Priority High
  • Reported Version
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Anonymous Submitter - 2006-03-04
Last edited by Daniel Stenberg - 2006-05-05

FS#4763 - Text viewer not full screen width.

The text viewing plugin on H300 seems unaware of the H300’s true screen width, so only uses ~12 characters per line.
Try and view /.rockbox/docs/* for example.

Thanks for the great software!
wehn.

The task depends upon
ID Project Summary Priority Severity Assigned To Progress
4873 Rockbox  FS#4873 - text viewer fixes  Very Low Low
100%
Closed by  Marcoen Hirschberg
2006-05-11 20:37
Reason for closing:  Fixed
Additional comments about closing:  

should be fixed in cvs

Rick Ennis commented on 2006-03-04 12:59

This is also a problem on the ipod video.

Dan Everton commented on 2006-03-24 12:27

Is this still a problem? I am unable to reproduce this issue in the simulator.

Fredrik Öhrn commented on 2006-03-24 13:15

I did some testing and I can only reproduce the bug when using the font helvR12, any other font and it works OK.

Frank Dischner commented on 2006-03-25 00:49

This bug is platform independant and specific to cached proportional fonts (at least helvR12 and unifont, maybe others). It is fixed in my (as yet incomplete) text viewer patch here http://www.rockbox.org/tracker/task/4873.

Admin
Daniel Stenberg commented on 2006-05-05 11:58

Frank, any news on this bug/patch ?

Tom Alsberg commented on 2006-05-06 12:05

This problem is not only on proportional fonts. Specifically, I am using the “unifont” font which seems rather fixed-width to me (I’m using it since this is the only font that supports a wide range of UniCode characters including Hebrew, latin-1, latin-2, and cyrillic, if I’m not mistaken), and the problem is still apparent. (RockBox version CVS-060505, iRiver H340).

If I set Wide View to Yes, the lines are too wide and I have to scroll left and right all the time.
If I set Wide View to No, the lines are too narror - about 12 characters, or half the length of a line that fits in the display of my H340 with the “unifont” font.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing