FS#4766 - Iriver h140 - Remote Buttons are going crazy

Attached to Project: Rockbox
Opened by Bodo (tsss) - Saturday, 04 March 2006, 14:12 GMT
Last edited by Christi Scarborough (christi-s) - Sunday, 19 March 2006, 12:20 GMT
Task Type Bugs
Category Remote
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Medium
Priority Immediate
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The function of the buttons on the remote is completely weired:

- The function of the Volume- and the Back/Next-Buttons are exchanged. Addionally the left/right functions are changed.

- Hold Button does not work at all.

- Shutdown of the player by pressing Stop for two seconds does is ignored.

Everything still worked with Version 2006-02-28. The Bug is present in versions 2006-03-02 and 2006-03-03.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Monday, 20 March 2006, 10:17 GMT
Reason for closing:  Fixed
Comment by Marco Fell (mfell) - Monday, 06 March 2006, 11:32 GMT
Same here, but not allways reproducible...

Version cvs-060227
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 06 March 2006, 11:36 GMT
Can you tell me if it is different if you start the iriver with the remote Hold switch On or OFF?
Comment by Heiko Niemeier (Taleel) - Monday, 06 March 2006, 11:58 GMT
Same on the h120. I see no difference if I start the iRiver with the remote Hold switch ON or OFF.

When I tried to switch off the iRiver with the remote's stop button the remote's display showed a lock symbol containing the letter "R".

Daily Build 2006-03-06 here.

Hope that helps.
Comment by Marco Fell (mfell) - Monday, 06 March 2006, 12:11 GMT
Hi again

Up to now, the behaviour seemed irreproducible to me. I just did a systematical (but only very short) investigation:

1. Remote on hold, switched on via main unit
after unlocking remote, the buttons are strangely switched:
Skip button -> Volume
Volume button -> Skip
Volume press -> rewind
Navi/Menu press -> Volume down
Rec press -> Vol down
Stop button doesn't react, as described in the last post

2. Remote NOT on hold, switched on via main unit
everything seems ok

3. Main unit on hold, switched on via remote
(this is the normal way for me)
everything seemed ok in the test just minutes ago.
But yesterday, after some hours of use it was scrambled again. Can't track down when it happened.

Hope this helps.
Comment by Marco Fell (mfell) - Wednesday, 08 March 2006, 09:39 GMT
I could find another situation, when the remote doesn't work as expected:

I switch on the player by pressing "play" on the remote and enable the keylock virtually the same time (before the firmware is loaded completely).

Then "Rockbox" doesn't recognize the stop button (exactly that Taleel describes), and the others are switched as I described erlier.

Might it help to scan the buttons earlier in the init routine starting @ line 194 in main.c? (Similar to the order in the "ifdef SIMULATOR" - statement...)

By the way: Thank you developpers all for your effort and the great results!!!

Comment by Bodo (tsss) - Wednesday, 08 March 2006, 11:33 GMT
I got some additional information:

I thought, it might just be a hardware problem with my player, but some others do obviously have the same problem...

You are right: The problem is not always reproducible. But when it happens: If you plug off and on the remote everything works again as it should be. This is why I thought it just may be a hardware problem with the plug.

And: This happens with Version 2006-02-28 as well, but not as often.

I am going to try an older version of the firmware. Perhaps it helps if you know the last version of the firmware where everything is working well.

Comment by Bodo (tsss) - Tuesday, 14 March 2006, 15:33 GMT
I know now when this problem appears:

1. Turn off the player

2. Press Play on the remote to turn it on

3. Immediately after pressing play turn on hold

When the display appears on the remote you will notice that there is no sign that hold is on. It should be, as you set in to on in step 3. Addtionally all the buttons are going crazy like I and others described it.

The problem appears already in firmwares from 2006-02-26. But I have not tested any earlier versions...
Comment by Aiolizator (Aiolizator) - Sunday, 19 March 2006, 13:37 GMT
Same problme with the H3x0 LCD remote on my H320.
Comment by Fredrik Öhrn (ohrn) - Monday, 20 March 2006, 10:12 GMT
This bug was fixed by the checkin "Iriver: Properly working remote type detection regardless of hold switch positions." on 2006-03-17.
I can reproduce the bug on older builds, on current builds it's gone.