Rockbox

Tasklist

FS#4875 - Remaining battery life reporting on H3xx different when using AC adaptor

Attached to Project: Rockbox
Opened by Tim Crist (ts-x) - Tuesday, 21 March 2006, 15:26 GMT
Last edited by Christi Scarborough (christi-s) - Wednesday, 22 March 2006, 13:03 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Medium
Priority Immediate
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Remaining battery life on the H3xx is reported differently depending on whether or not the AC adaptor is inserted. It's almost as if the remaining time until the battery is fully charged is shown when charging via AC. This is a new behavior, that I would guess was introduced maybe three to four weeks ago (beginning of Mar-06). A few comparative examples of reporting differences: (Example 1) Running from battery = 7h 25m, plug AC in = 0h 13m (Example 2) Running from battery = 6h 1m, plug AC in = 1h 30m (Example 3) Running from battery = 5h 43m, plug AC in = 1h 58m.
This task depends upon

Closed by  Brandon Low (lostlogic)
Wednesday, 05 April 2006, 12:07 GMT
Reason for closing:  Wont Fix
Additional comments about closing:  Like the comments say.
Comment by wehn (wehn) - Sunday, 26 March 2006, 12:23 GMT
I think this is a feature, not a bug. It now seems to show time left till fully charged.

as in CVS:

2006 13 Mar 16:11 Miika
Charging state reporting for iriver players. Values calibrated with 1900 mAh Ionity battery; might need recalibration with the stock battery.
Comment by Matthias Mohr (aka Massa) (mmohr) - Monday, 27 March 2006, 14:24 GMT
yes it's a feature - source code differentiates between charging and discharging and
gives back either the expected remaining runtime or the expected remaining charging time.

Loading...