Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Recording
  • Assigned To No-one
  • Operating System Archos Recorder
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Peter200lx - 2006-03-26
Last edited by bagder - 2006-04-03

FS#4926 - iTunes not handling recorded MP3's

I record the sermons for our church on the Archos Recorder V1. Some people have mentioning that on their iPods the sermons are only 20-40 minutes long, even though when recorded the mp3s are around 50-70 minutes long. I tested the ones they were talking about and it worked fine in Winamp and Window$ Media Player. I then installed iTunes :-P and tried it with that. Almost none of the recent sermons are the right length. Is there some error in the recorded MP3s that would cause this? I’m not sure how to help them, other then telling them to switch ;-). Any ideas how to fix this? I’m willing to run the MP3s through a program on my computer if that is what it takes to make the recordings work.

Closed by  bagder
2006-06-21 11:15
Reason for closing:  Invalid
Additional comments about closing:  

If 4 out of 5 independent players play the file fine and the 5th (iTunes) barfs, I say it feels most likely that the problem is in… iTunes.

Project Manager

My first suggestion would be to run it with the vbrfix plugin. Hold ON+Play on the file in the browser, then select “Open with” and “vbrfix”.

Hmm, that didn’t make iTunes read the whole file. It still says that a 55 minute sermon is 15 minutes long. I did some testing and found that the problem is when iTunes imports the MP3 file. I copied the same MP3 to a Nano that has RockBox and it plays fine. I also tried putting the same MP3 file onto the Original iPod firmware with YamiPod (http://www.yamipod.com/main/modules/home/) and it saw the whole length of the sermon just fine. When Recording on the Archos Recorder V1, I have the settings as such:
Quality 0
Frequency 16Hz
Source Line-IN
Channels Mono
Independent Frame NO
Time Split OFF
Prerecord Time 5s

I also tried using the vbrfix plug-in without success, once it make iTunes get a couple more minutes, but still no where near the full length.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing