FS#4934 - Backlight won't turn off on 5G

Attached to Project: Rockbox
Opened by stringZ (stringZ) - Monday, 27 March 2006, 14:00 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When I set the backlight to be turned off in the configuration menu, it turns it on permanently as I had chosen the On option instead.
This task depends upon

Closed by  Hristo Kovachev (bger)
Saturday, 01 April 2006, 12:21 GMT
Reason for closing:  Accepted
Comment by Ralf Herz (herz42) - Monday, 27 March 2006, 22:01 GMT
The attached patch should fix the problem.
It was caused by a signed/unsigned problem.
Second bug that is fixed: buttons not working if backlight is set to be statically off.
Comment by Ralf Herz (herz42) - Monday, 27 March 2006, 22:29 GMT
ok, more pretty this time, but same functionality
Comment by Ralf Herz (herz42) - Monday, 27 March 2006, 22:37 GMT
hmm, I have to correct:
the second patch might be confusing if someone wants to use the is_backlight_on() function later on, as it returns also true if the backlight is switched off statically with this patch :(
So take whatever patch suites you more... or do it in a more straightforward way