Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Anonymous Submitter - 2006-03-31

FS#4975 - No Charge with USB Power Adapter pn G5

If u Use Ipod USB Power Charger (Official Charger with APPLE)
the IPOD spins up in Diskmode and after Few Secon a Reset comes,
then comes up a Rockbox Charge Symbol and than it resets again to discmode,
then it spin up in discmode … and so on … its a very bad Loop (and my harm the RockPod. :( )

it must be possible to charge the RockPod while Playing (the orginal Firmware do that)

Closed by  linuxstb
2006-04-08 20:21
Reason for closing:  Duplicate
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407 Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

Duplicate of http://www.rockbox.org/tr acker/task/4724

Two problems here:
1. We don’t know how to differentiate between an USB data connection to a computer and just ‘power over USB’. So rockbox always assumes a connection to a computer and switches to built-in USB disk mode.
2. When preventing to switch to usb disk mode (by pressing menu button while inserting the usb cable), the usb charging circuit is restricted to 100mA. So it will take more than a day to fully charge while running rockbox (at least on my ipv-60gb). But it ‘works’.

btw: My ipod doesn’t automatically reset after exiting USB disk mode, just showing the big checkmark. Anybody knows how this behaviour can be changed?

Hmm,

the original Firmware can diff. between usb data connection and Power over usb … (but its a big problem that rockbox boot to apple os and charge some seconds and jumps back to rockbox … and than jumps back to apple os.. and so on)

is it possible to pushe the 100mA up to 500 or more?

Im not sure but i belive the apple os
different usb data connection from Power over usb very easy,
if DATA + and DATA - = Ground (it will think its a USB Charger

greetz from Berlin :)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing