FS#5100 - WPS gets out-of-sync with playing song

Attached to Project: Rockbox
Opened by Joseph Hoh (SlaytanicLemmy) - Wednesday, 12 April 2006, 00:29 GMT
Last edited by Brandon Low (lostlogic) - Wednesday, 12 April 2006, 03:43 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To Brandon Low (lostlogic)
Operating System iPod 5G
Severity Medium
Priority Normal
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


This appeared somtime after the 03/20/2006 version - I was using that version for weeks until 4/8.

When playing a playlist, rockbox will change the song to the next track after the current track is complete, but the currently playing song stays the same and the next song will show the currently playing song. After this, both the currently playing and next song will increment, but they will always be out of sync - with the currently playing song displayed as the next song.

I know that this happens on rockamp, joshpod, and nudel5g - it may happen on others.
This task depends upon

Closed by  Brandon Low (lostlogic)
Tuesday, 18 April 2006, 16:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  Great, glad to hear!
Comment by Brandon Low (lostlogic) - Wednesday, 12 April 2006, 03:44 GMT
It doesn't matter what theme you are using. There are several open issues in the software codec playback system that I have been working on for the past couple of weeks, see the SoftwareCodecPlayback wiki page for more information.
Comment by Brandon Low (lostlogic) - Tuesday, 18 April 2006, 03:08 GMT
Is this dead now?
Comment by Joseph Hoh (SlaytanicLemmy) - Tuesday, 18 April 2006, 16:14 GMT
Yes. OK to close. I think it is solved in the current builds.