FS#5110 - Fix for crash in voice menus

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Wednesday, 12 April 2006, 20:49 GMT
Task Type Patches
Category Settings
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The problem with voiced menus crashing seems to be caused by an undetected wrap around in the voice queue - the read pointer ends up "overtaking" the write pointer.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Thursday, 27 April 2006, 15:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  superceded by lostlogic\'s work
Comment by Steve Bavin (pondlife) - Thursday, 13 April 2006, 09:00 GMT
Oops, I think I diffed from the wrong level - this one's the same but taken from the correct point (I think).
Comment by Steve Bavin (pondlife) - Thursday, 13 April 2006, 16:55 GMT
Please ignore this patch for now; I've found a case where all voice playback stops which may be caused by it (or may not be).