FS#5136 - Extended FFW causes HDD read then player lockup

Attached to Project: Rockbox
Opened by Anonymous Submitter - Saturday, 15 April 2006, 22:15 GMT
Last edited by Brandon Low (lostlogic) - Monday, 17 April 2006, 22:46 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Brandon Low (lostlogic)
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Hardware: iHP120
Bootloader: v6 (04/15/06)

Found in bleeding edge version 04/15/06 and the dailies prior.

Temporary fix: Only HDD read (not player crashing) present in 04/05/06 daily. Currently using this.

When navigating a long song (example: 1 hour DJ sets) using exponential speed increase (any multiplier), and the time fast forwarded in one burst exceeds a certain threshold, the player locks up requiring a hard reset.

Indicators that the threshold has been exceeded are the HDD light lighting up for a 200ms interval during the seeking. Once the joystick is released, the hard drive does an extended read operation, then the crash occurs. This is visible by all animations in the WPS ceasing.

Notes: Probably due to the recent, massive rewrite being undertaken on the playback section, this I do not feel as a high priority; I simply want to let you know it is there.
This task depends upon

Closed by  Brandon Low (lostlogic)
Tuesday, 18 April 2006, 16:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  This is pretty much a dupe of another bug now fixed, so should be fixed, please reopen or create another if I\'m wrong.
Comment by Brandon Low (lostlogic) - Monday, 17 April 2006, 22:46 GMT
Does this still happen in the latest CVS?