FS#5144 - iPod 4G Color hangs on splash screen since CVS-20060415

Attached to Project: Rockbox
Opened by Stephen Caraher (moskvax) - Sunday, 16 April 2006, 06:32 GMT
Last edited by Dave Chapman (linuxstb) - Thursday, 27 April 2006, 20:10 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod 4G Color
Severity Critical
Priority Normal
Reported Version
Due in Version Version 3.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The ipod will load as far as the logo and version number splash screen, but does not go any further than that. The backlight remains lit. No error messages, just a hang. The same ipod boots and operates fine with CVS-20060414. Still hangs in CVS-20060416.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 28 April 2006, 08:28 GMT
Reason for closing:  Fixed
Comment by James reeves (haibane) - Sunday, 16 April 2006, 19:55 GMT
Aside from that, when it hangs sometimes it passes and it also crashes later on. Lots of issues playing things with the new firmware post thursday.
Comment by Richard (ribi) - Tuesday, 25 April 2006, 19:36 GMT

If you're using CVS, change the following line in: firmware/export/config-ipodcolor.h

It's just a workaround until the CPU scaling gets fixed.
I'm quite new to Rockbox but will try to look into it.
Any help from anyone is greatly appreciated.

Comment by Dave Chapman (linuxstb) - Wednesday, 26 April 2006, 07:37 GMT
I'm not denying that CPU scaling could be causing problems, but I've had no problems on my 4G Color since I enabled CPU scaling for it in Rockbox. I would also have expected a lots more complaints from other 4G users if the CPU scaling was causing crashes.

There has been major reworking of the playback code over the last few weeks - that often caused freezes (but it should be relatively stable now). Other people have reported that the Voice UI and the use of TagCache has caused freezes. Can you please try the following, and confirm if a) you still get freezes; and b) that disabling the CPU scaling fixes it?

1) Delete your existing rockbox.ipod file and .rockbox folder
2) Install the very latest CVS/Bleeding Edge build.
3) Turn the hold switch on when booting Rockbox - this resets your settings.

Comment by James reeves (haibane) - Thursday, 27 April 2006, 15:29 GMT
The above comment is what worked for me when I posted about this earlier
Comment by Dave Chapman (linuxstb) - Thursday, 27 April 2006, 20:10 GMT
Can you confirm that you no longer have this problem?
Comment by Stephen Caraher (moskvax) - Friday, 28 April 2006, 08:15 GMT
yes, the problem is gone now.