• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Settings
  • Assigned To
  • Operating System Iriver H100 series
  • Severity Critical
  • Priority Very Low
  • Reported Version
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by talksten - 2006-04-23
Last edited by petur - 2006-04-30

FS#5215 - Resume Playback does not work

Though I have set “Resume on Startup” to “Yes”, my IRiver H140 does not start playback when booted up. Instead, it lands on the file list.
This worked fine in earlier releases.

Closed by  lostlogic
2006-05-02 14:41
Reason for closing:  Fixed

I have the same problem except that resume causes it to try and play the last file, but instead it just locks up, sometimes with button control sometimes without. works fine so i went back to it and both exhibit the same problem with the resume

all installs were tried both installing over the top of a previous installation and also on a clean directory (deleting ./rockbox and rockbox.iriver first)

This sounds like the same bug as I reported on the “Calling testers: Playback SHOULD be working” thread on the form and some other people are reporting as well.

I am still having the failure to playback on resume bug with last nights CVS build if I let the player power down and on its own then try to resume from a recesnt bookmark and can reproduce it with the following settings and steps.

- Shuffle = No
- Repeat = Off
- Resume on Startup = Yes
- Fade on Stop / Pause = No
- Enable Crossfade = off
- Tag Cache

- Bookmark on Stop = yes Recent only
- Load Last Bookmark = yes
- Maintain a List of Recent Bookmarks = yes

- Directory Cache = On

1. Now create a playlist with a few tracks on it and start it playing.

2. Let it play for a few moments then hold down stop to get it to create a bookmark and shutdown.

3. Press play to boot rockbox again and pause the track as soon as it boots without letting it play more than a second or to.

4. Wait for power saving to cut in and shutdown the player.

5. Press play to boot the player and the player should now boot up and say that it is playing but fail to resume playback without displaying an error message.

You can then go into directory view and select any file you like but it won’t start playing the file.

You should now be able to shutdown and boot the player as many times as you like and still have broken playback until. You press the reset button or clear the settings on boot.

After clearing the settings you can reload your saved setting and load the saved resent bookmark and continue playing as normal.

I have attached a copy of my config file to help track down which option is causing this.

This also sounds like the same bug being reported here by roolku and here by Neff on the same thread of the form as the symptoms are the same.

“Load Last Bookmark” setting seems to be broken alltogether in resent builds now.

I have it set to yes but my h140 now loads into directory view and pressing play just displays the “Nothing to resume” message.
Loading the resent bookmark manually still works though.

I am testing with the 1 May 12:54 CVS build.

I believe I’ve fixed this in the latest CVS build. Please verify.

I installed the latest build but still have problems with resume at startup. It just loads into the directory and displays “Nothing to resume” when I press play. This happens on a iriver H340.

Your fix for the lockup is looking good so far as I have let my h140 shutdown automatically a few times to test your fix and it has not yet locked up on start-up.

Sadly it also seems to have totally broken Bookmark support loading ether an automatically created resent bookmark or a manually created one now results in the file starting playing back from the beginning not the point at which the bookmark was created.

I will do some more testing with some of my other .cfg files I use for listening to music as well as audio books just to make sure the lockup is fixed and report back.

Daniel_A: Your problem sounds like something else. Does resume work if you don’t have “Resume at startup” enabled?

It works now. I had to do a clean install.


Available keyboard shortcuts


Task Details

Task Editing