• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Drivers
  • Assigned To No-one
  • Operating System All players
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Tobu - 2006-04-23
Last edited by linuxstb - 2006-05-20

FS#5217 - Disk label disappears

The fat disk label on my iAudio X5 disappeared at some time after I’d switched to rockbox. This could be a filesystem bug.

Closed by  bagder
2007-05-19 16:03
Reason for closing:  Out of Date

Mine also seems to be gone, ipod nano.

petur commented on 2006-05-04 19:42

please add as much details as possible:
- what was the exact label (short or long filename system)
- anything you did before the label vanished

preglow already mentioned seeing it after removing a directory. But not 100% sure. Please give more input…

I can’t replicate this error.

I have tried:
- deleting a file (on the player)
- deleting a directory (on the player)

The disk label remains unaffected.

(ver. CVS-060529, 5G iPod)

Update: I have managed to replicate this bug: it occurred to me when the iPod_Control (hidden) directory was deleted or renamed.

After deletion/renaming, I set the name using Windows Explorer (would expect the same to work for other OSes) and it seems to have stuck permanently.

I tried to replicate the same bug with a differently named directory and no change was observed. A hidden directory with a long filename was created in the root and it was not affected.

Has anyone seen this problem recently? If so, a repro recipe would be useful; I’ve tried to reproduce it here, but no luck yet.


Available keyboard shortcuts


Task Details

Task Editing