Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Critical
  • Priority Very Low
  • Reported Version
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Anonymous Submitter - 2006-04-27
Last edited by linuxstb - 2006-05-20

FS#5242 - Bugs in the latest build 4/26/06

I posted this on Mystic River, thought it was a problem with my unit but as I installed an older build have not have had the problem

you can see what was suggested and what I tried re erasing files, resetting defaults etc.

http://www.misticriver.net/showthread.php?p=437667&posted=1#post437667

First message:

To cut to the chase, iRiver replaced my h120 with an h140 which would seem like good news.

As far as I can tell the iRiver firmware seems to work okay, so I am assuming there is not a problem with the hardware.

At first I had some problems getting this refurbished to show up on my computer (xp). I reinstalled the software and that seems okay now.

The weird problem is, after loading about 20 gigs of files onto the new hd and upgrading the firmware to Rockbox (something I’ve done plenty of times before on the h120), the unit played fine at first but then after turning it off, the firmware loaded but no songs would play.

I reinstalled the firmware, repatched from scratch, uploaded the lastest daily builds etc. Sometimes w/o any effect and sometimes it would work until I turned the unit off.

Once I saw the message flash on start up unable to load playlist file or words to that effect, so I created a playlist file etc, erased the old one, tried all sorts of things. After many attempts finally got it working, started customizing the settings and turned it off, same result. Files don’t play in Rockbox, but play in iRiver firmware mode. I noticed once a message saying S codec failed or something similar as unit was shutting down.

on the reboot I get ?kb for file size (first time, when it plays it shows up correctly)

most of the other functions, navigation, stop/off etc seem to work.

the screen looks like this

filename.ogg
(root)
(root)

0:00/):00 2:18
?kBit (no id3)

File is not in root dir.
I never had a problem like this with my 120’s. I can’t return it to iRiver unless there is a problem with the iRiver mode and there does not seem to be (radio, recording, playback all work)

DOES ANYONE have a clue about what’s going on?

Closed by  linuxstb
2006-05-25 20:02
Reason for closing:  Invalid
Additional comments about closing:  

After more than 3 weeks the original (anonymous) poster hasn\'t responded to a request to try and recreate the bugs with a current Rockbox build.

Try the latest CVS.

Can you try the latest Rockbox build and let us know if this bug is still present?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing