Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iPod 4G Color
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by haibane - 2006-04-28
Last edited by linuxstb - 2006-05-25

FS#5248 - Crossfade isn't working properly anymore

OK, so before the last 2 or 3 updates, the crossfade function has worked flawlessly, but now it doesn’t even crossfade anymore. I am using the same settings as before. So I don’t know what it is, but oddly it isn’t working. Thanks in advance

Closed by  RaeNye
2006-09-18 18:31
Reason for closing:  Works For Me
Additional comments about closing:  

Please reopen if the problem persists.

I’ve got an IAudio X5 60GB.
Crossfading was last working with daily build rockbox-iaudiox5-20060418.zip.
With today’s (~20060428) CVS Builds, it is working (again), but only on normal track changes.
It doesn’t crossfade on track skip, even if crossfade settings are set to ‘Always’!

Greets, Taurus

I’m sorry, but I have to correct the above comment:

It seems that in versions ⇐ rockbox-iaudiox5-20060418.zip, the Fade-Out Mode ‘Mix’ did not behave as it does in current versions.
I’ve now set it to crossfade and have the effect I wanted ;)
Still, it doesn’t always crossfade! It only crossfades on ~half of the manual skips.
Also, when skipping 2 or more times in a row, it hard-skips the tracks.

Track skipping repeatedly will not crossfade, the buffer doesn’t have a chance to fill to allow for a fade. This doesn’t really sound like a bug to me, are you sure that it fades less often on manual skip than on the old builds? Manual skip fade is difficult to initialize, because often a manual skip is pressed when the buffer level is low, and the fade can’t be processed properly.

I don’t know if it really happens more often than before. I’ll test it!

What you’re saying is exactly what I’ve thought (the buffer having no time to refill).
It is still a bug to me, because:
I assume that the same effect occures when crossfade setting is set to ‘Track skip only’.
Especially then, but also when set to ‘always’, I want to (yes, I’m being very selfish, sorry!) have crossfading! As a simple user, I don’t care about the buffer.

What I suggest is that the track doesn’t skip until the buffer is properly filled. This will slow down the skipping process in some cases, but if this annoys you, this could be avoided by setting an additional option ‘Always but on skip’ (if this doesn’t already exist. Dunno what ‘Shuffle’ does exactly…).

What Taurus is experiencing is almost identical to what my issue is on the latest build

In short, no. We will never delay the track skip until the buffer fills enough to crossfade. The UI lag and complexity penalties for such a thing are too great.

James, is this something that you can clearly say has changed in new builds compared to older?

definately. This is one of the things that got me into rock box. I have been using it on my ipod live and just recently noticed that the playback no longer fades using the same exact settings I have always used.

It seems that crossfade works every time if I browse to the next (or previous) track, rather than using track skip. I would have though that with random-access browsing it would be more likely to fail as the required audio would almost certainly not be buffered… this is on an IRiver H340 with a current CVS build.

Brandon, I think that’s wrong, you should exactly fill the buffer to crossfade every time (same with beeping). The user experience of ‘intermittent features’ is horrible. If the user wants crossfading/beeping, give it to him reliably.

Let me qualify that, if you’re multi-skipping quickly in succesion, then by all means don’t crossfade. However I’m seeing skip crossfading not work most of the time even in the middle of tracks, and if that is caused by the buffer being in the wrong state, then the buffer should be refilled.

(As said before) I totally agree with gl.tter.

I cannot confirm (with numbers) that crossfade is working worse with actual releases than with releases < 20060418. But I have the feeling that it does.
On my iAudio x5 I often have skips on track skipping instead of proper fading. If you don’t touch the dial, crossfading works fine, of course. But if you do a manual skip, then it only works 50-70% of the time (not measured values, just my feelings).
Of course if you’re being mean and skip right after track change, the failure rate is even much higher. But in the past few weeks, I was surprised by the count of fading failures of skips in the middle of a track, where I thought the player was just running and not reading/refilling the buffer or something like that.

Would it help to increase the anti-skip buffer (currently to default 5 secs)?

Please could anyone who’s seeing this problem please try patch #5751 - http://www.rockbox.org/tracker/task/5751 It may be a red herring, but this Works For Me and I’d like to see if it works for you (and doesn’t cause lockups).

Miika has done some work on this recently, please try a new CVS build and report back if the crossfade is still failing.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing