• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iPod 4G Color
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Version 3.1
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by JeffElkins - 2006-05-01
Last edited by nls - 2007-07-08

FS#5264 - System Freeze: iPod Photo 60GB

System freeze on playback: iPod 60GB Photo using 4/30/06 CVS.

After 30 or so minutes of playing the system freezes. I tried plugged in (USB - A/C) and running off battery. Highly reproduceable here.

Closed by  nls
2007-07-08 11:30
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

This has been fixed by amiconn's recent changes to the clock setup code.

You haven’t included steps for reproducing. For example, is there any particular setting that causes this? Have you done any experimenting to see what causes this?

Mainly I tried plugged in to a/c, usb and on battery. This was also with a cleared config file. No settings applied, no special theme, etc.

Freezing here too as of 5/1/06 build on iPod color 60gb with clean install, cleared config.

slip commented on 2006-05-01 20:17

Same problem on 4G Grey Ipod. I get regular system feezes

You haven’t included steps for reproducing.

I thought about this, wondering if it was mp3 bitrate. So I queued up both 128 and 192 mp3s. No difference, both freeze after 30 or so minutes.

Same here iPod Photo 60gig. Seems completly random but happens often.

mede commented on 2006-05-10 08:04

have the same problem with my ipod photo 30G

if iam hearing sound the system freeze totaly after some minutes and
i have to reboot the ipod.

i am not sure but in older versions of rockbox i had no so problem.

No joy yet with current CVS builds- Freezes every time in under an hour. I’ve been forced to use retail due to the WAF (wife acceptance factor). Is this being worked on by developers?

Rockbox is currently in feature freeze prepping for the iRiver release. iPod-specific bugs really don’t have much priority until then.

OK. I’ll keep checking back.

mede commented on 2006-05-11 09:03

rockbox is a cool thing but this bug is very very annoying !
i am about to take a mental demage because i have to reboot my ipod
every 10 minutes …

please please have a look at this …

slip commented on 2006-05-11 10:36

On my 4G Greys IPOD it seems to be worse when using crossfade, also when shuffling through a large playlist.
Even when I dont use these it still hangs unexpectantly halfway through a song and the only way to recovber is through a reboot.

I ran a defrag on my 60gig, promblem is WAY better! Still hangs occasionally but nowhere near as often.

I watched the same bug on my ipod 60gb color! The System freezes and sometimes the background image of the wps ‘fades’ slowly out. Then I have to reboot by pressing menu and select.

this happens to me on my first gen ipod mini. after playing music for about 30 min ( i tried on all of my mp3s so bitrate or anything is not a factor) the ipod will simply freeze and a reboot is necesarry. one time i got a message saying ‘failure at 00417’ (not exact number but it was similar to that).

I have experienced this phenomena on an 4G Greyscale IPOD. I have used this device (with crossfading) for early music a parties (the non-mixed portion) of a dj set. One thing I have noticed is when you navigate the menus and make playlist changes every 1-3 minutes it tends to ward off the crash. In fact I have been able to pretty reliably prevent the freeze-ups by just navigating to a new menu every so often. Not sure how much help this is, but one thing I can figure: If you are making playlist changes the HardDrive is forced to spin up. I’m thinking it’s something to do with the caching / disk spindown.

This appears to still be happening with the nightly builds; I see it regularly on my 4g greyscale. Quite annoying.

I have a 30G ipod photo. What makes this bug most annoying is that rebooting is difficult. Perhaps bad keys on my iPod? I must try the reboot procedure several times (hold on/off, hold select & menu for 6 sec) until I get it back.

You don’t have to do hold on/off. It’s not necessary for *just* rebooting your iPod.

spray commented on 2006-08-14 13:04

I also experience complete freeze with my iPod colour/photo 40Gig. It happens randomly after 10 to 60 minutes, even when the iPod is fully charged or connected to the dock. The screen show a part of the display info. Same problem with all standard themes included in the nightly releases. Has to be re-booted. I am never using crossfade and I didn’t change anything in the sound features. I am not using playlists. What’s the problem ? :((
thanks for your help

spray commented on 2006-08-15 11:40

I see on all ipod related forums that many peoples have freeze problems with ipods, even 5G. It’s not a Rockbox bug at all ! The strange thing is that nobody cares at Apple. They just keep telling people to reboot the ipod :(
My next mp3 player will not be an ipod !

Woody commented on 2006-09-07 15:14

This is really disappointing. I bought an iPod photo 60 color because it is supported by Rockbox.
However it doesn’t play longer then 20 minutes on a good day.

Now I have to choose between my old Archos or the Apple firmware (that I really
don’t like) on my iPod

I know you guys can do magic so I hope it is fixed soon.
Keep up the great work !!!!!!

iPod 5G (60Gb), and a recently custom built Rockbox from the repository does not show these issues. This custom build includes several unsupported patches. I’m currently playing the iPod continously for an hour now. Generally playing with most settings and features. Enabled battery_test, using crossfade, used iPod_Control/Music files, ran TagCache while playing an MP3. All of my audio files are MP3 VBRs which I ripped off my own CD collection, properly tagged with EasyTAG, and some tags contains Unicode (which doesn’t display properly on the iPod but displays correctly on the simulator). After TagCache, I’m now playing off the cache, and an auto-generated playlist.

Yesterday, before I installed Rockbox I used the Apple firmware and played continously for 8 hours. Played some CNN video podcasts.

Tech details:
downloaded and built CVS (2006-09-12): binutils-2.17, gcc-4.1.1, gdb-6.5
patched: ipod_brigthness_2.patch, menu_buttons.patch, mp4.1.2.patch, peakmeter_margins_20060831-MM.patch, scroll_margins_20060829.patch, select_ipod_memory_2_(senab_sync).patch and unplug.patch
WPS: UniCatcher (needed for my JPop)
removed uneeded files, extraneous languages, unused plugins (ie games, demos, rockdoom, rockboy)
(only issue I encountered was that the bootloader I built did not boot. i used the bootloader from the site and everything was fine)

Seeing as this bug was reported for the iPod Photo, which is a 4th generation iPod, it shouldn’t be happening on a 5G.

skymt commented on 2006-09-16 14:32

I’d just like to add my iPod to the list of crashers. 1G mini, yesterday’s build, freshly formatted. Like posters above, activity (such as navigating menus) seems to prevent crashing. Otherwise, I get 10-15 minutes. It doesn’t seem related to settings or themes.

skymt commented on 2006-09-16 14:48

Never mind the workaround. I just had a crash around 10 seconds after using the menus. Still working on a cause.

I can confirm the same thing happens with my 60GB 4G photo. Playing FLAC files, though, not MP3s. Both using playlists, and direct track selection. Seems to happen anywhere from 2 minutes to 30 minutes after starting playback, but it is definitely repeatable, and predictable. Just seems to be non-specific to any settings I can pin down.

Tried 3 CVS‘ed firmwares each about a month apart in age, with the most recent being CVS-06-06-09.

I thought of trying a 4th, newer firmware, but based on other recent comments, I’m guessing it won’t be fixed as-of-yet…

Don’t know if this will be helpful or not, but I’ve had various RockBox builds on a 4g 60 gb Photo for over a month. All have frozen, requiring reboot to get out of, but with varying periods of normal operation. I use no eq, 30s anti skip, no crossfeed, have tried directory cache on and off, and use a basic wps (boxes).

fwiw, the best runtimes (hours rather than minutes) have been with a 9/8/2006 build, which I have gone back to. The absolute worst freezing and even inability to boot experiences have been with 9/16 and 9/18/2006 builds - they are completely unusable.

Perhaps this information will be helpful in figuring out what is happening on the 4g color/photos.

I experienced fairly regular crashing on my 60 GB iPod Photo, but it was more common when playing more CPU intensive formats, like MP3 or SID. I saw it recommended that I should try disabling frequency scaling (remove the #define HAVE_ADJUSTIBLE_CPU_FREQ from config-ipodcolor.h), I tried this and I have not experienced a crash since.

Good to hear someone is having some success with this! Would the fix you described work on the 4g grayscale ipods as well? And if so, would you mind detailing the fix a little bit?

makeage has a thread about this here: He has a 4g grayscale iPod and it works fine for him. Battery life takes a hit, but you must ask yourself if you want to run for two more hours or reboot every 20 minutes… I have a patch here: That fixes frequency scaling on my photo (several days with no crash), but mikeage had no such luck with it on his grayscale.

(found this just after submitting a bug regarding freezes on a 4g)

After installing the cpufreq path build on my 4g it appears that the freezing has gone (or at least I’ve had no freezing for the last hour or so).

Please can anyone who’s had this problem try the latest bootloader and build, then report back if they still have freezing issues?

If it’s all quiet, I’ll close this bug.

I will. I’ve got old stuff on my iPod so let me load the latest bootloader/build, and give it a spin for a day or so, and I’ll report on how it goes….

I know you asked for a report if there are still issues, but I’d like to report that I’ve been running it for a few days now (60GB Photo) and experienced no freezes.

I’m still having issues. Hardware is an iPod 60GB Photo. Based off this thread I installed the latest daily build and immediately started having freezes immediately after startup (<5 minutes). Thinking I might have had old gunk I deleted my .rockbox directory and reinstalled using the latest daily, latest fonts, and uninstalled and reinstalled the bootloader. This led to a situation in which Rockbox doesn’t even boot most of the time (maybe 1 out of 5 tries). Thinking it might still have something to do with old stuff lying around I opened up the latest version of iTunes and did a restore on the iPod with their latest software, set all the settings to not automatically update anything, then loaded into disk mode and reinstalled Rockbox with 4-22 daily, fonts, and bootloader. I am having the same problem, being unable to load into Rockbox.
Actually, the first time I started it Rockbox did load, however it froze after ~2 minutes and I have been unsuccessful at getting it back running again.
After restoring to my last known good build, a bleeding 070308 build with the COP11 patch before it was committed, Rockbox immediately loads and I have no further issues. There are still intermittent crashes characteristic with the stability reported during the COP11 patch development (somewhere between 1-8 hours with no consistent pattern). At least it works.
So, to answer the question, the latest bootloader and build cause major issues on my pod.
Is there anyway I can take better logs/low level data to try and backtrace the crashes? I’m not sure if there’s a plugin to do that or not. Let me know if there’s any way I can help–my coding is not up to the level of this project, but I’m fairly proficient at computers in general.

I have been experiencing freezes again as well, I haven’t gone back to see when this began yet. No apparent problems booting, but the same sort of random freezing behavior we used to see.

I’m having mine lock up and display “Data Abort” as soon as I try to play a song. All the plug-ins work fine though.

This ‘data abort at XXXXXXX’ problem has been plaguing me for months - rockbox is completely unusable on my 60 gig ipod :/ Unfortunately, I no longer have a build that works at all.

Unless anyone has a better suggestion, I’m replacing the original apple bootloader and going to try and figure out how to use >gulp< itunes.

To clarify - my experience is the same as the one that chad describes.

Chad and Salacious. Sounds very much like you need to update your bootloader to the latest one, then put the latest SVN build on.

This particular issue refers to random freezes after a while, not immediate data aborts.

Thanks Steve. I didn’t realize there was a new boot loader as well as a new build.

thanks - I’ll try that and report back


Available keyboard shortcuts


Task Details

Task Editing