Rockbox

Tasklist

FS#5312 - Track change problems with TagCache

Attached to Project: Rockbox
Opened by Dmitry A. Borzenkov (shiroineko) - Sunday, 07 May 2006, 22:13 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System iPod Nano
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date 2006-05-08
Percent Complete 100%
Votes 0
Private No

Details

There is some strange behaviour when TagCache navigation is used. All situations encountered with crossfades, shuffle, repeat all turned on and off in all combinations. None of these encountered with regular 'file system' style navigation.
Here are some patterns:

1. Regular Playback:
1.1 When track ends, Rockbox doesn't switch to next track, but starts playing the same track again.
1.2 Sometimes Rockbox inerrupts somewhere in a song and starts playing
1.2.1 next song from the same position it was in previous song.
1.2.2 the same song from the beginning
1.3 After track ends, player makes a hissing sound and then either:
1.3.1 continues hissing until reboot
1.3.2 plays a short part (about 10-15 seconds of song's tail), then either starts song from the start or jumps to a random place in the next song.

2. Manual track skip (every action described as a result of pressing 'next track' or 'previous track')
2.1 the same situation as 1.3.1 and 1.3.2
2.2 starts the next track from the same position as it left the skipped track
2.3 instead of playing the next track, jumps to 10-15 seconds before the ending of current track while display shows next song correctly.
2.4 if 2.3 happened and I press 'next track' several more times, then each press results in several resultr randomly:
2.4.1 begins playing previous song from random position
2.4.2 starts hissing ref. 2.1
2.4.3 starts playing some random previous song from random position.

In every situation WPS shows correct current and next song from selected set of songs. This behaviour disappears after reboot but appears again after 3-4 songs played or skipped.
This task depends upon

Closed by  Hardeep Sidhu (hardeeps)
Tuesday, 09 May 2006, 14:46 GMT
Reason for closing:  Fixed
Comment by Hardeep Sidhu (hardeeps) - Sunday, 07 May 2006, 22:37 GMT
What version of Rockbox are you using?
Comment by Dmitry A. Borzenkov (shiroineko) - Monday, 08 May 2006, 08:50 GMT
Tried two daily builds from 2006-05-06 and 2006-05-04
Comment by Hardeep Sidhu (hardeeps) - Tuesday, 09 May 2006, 01:05 GMT
I can't reproduce this with latest CVS build. Would you provide a copy of your config file to see what option I may be missing.
Comment by Dmitry A. Borzenkov (shiroineko) - Tuesday, 09 May 2006, 09:16 GMT
Strange. The situation is always reproducable here. :-\\ Well, here you go with config. Hope it will help...
Comment by Dmitry A. Borzenkov (shiroineko) - Tuesday, 09 May 2006, 14:08 GMT
I've figured out a way to reproduce behaviour (at least, for me it works always)
1. start playback.
2. go to tag database, select some small subset of songs, like one album of some artist, make some manual track skips (generally, at this time, everything works ok)
3. go to tag database again and select 'Tracks', then start playback. At this point it either starts to dibehave or sometimes everything goes wrong after some more manual track skips or some fast forwards and manual skips.
(at the moment, e.g. I'm listening the same track for the third time and I don't believe this is the result of a random selection from 170 tracks:))
Comment by Dmitry A. Borzenkov (shiroineko) - Tuesday, 09 May 2006, 14:15 GMT
And one more pattern.
After pressing 'next track' the WPS shows the next track being played from the same position the previous track was interrupted at, and the player actually plays the previous track's ending. When that track ends, player will start playing it againg while WPS will freeze when progress bar reaches its full length. pressing 'next track' at this point will make player jump to a random place in a random track and WPS will show another random track from the beginning.
Comment by Hardeep Sidhu (hardeeps) - Tuesday, 09 May 2006, 14:45 GMT
Thanks for the detailed steps. This should be fixed in latest CVS.

Loading...