Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To
    petur
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Shorty_0708 - 2006-05-12
Last edited by petur - 2006-05-18

FS#5351 - wps overlay

i have diff config files for different times of the day. When i switch from one to the other, the wps is partially the old and partially the new one… Does anyone know about this?

Closed by  petur
2006-05-18 22:45
Reason for closing:  Fixed
Additional comments about closing:  

will still mess your wps if your config file contains a different font!

I’m guessing one of them has a backdrop, and one of them doesn’t, and it ends up using the backdrop set by the old one. I think that backdrop priority doesn’t quite work out yet.

Part of the problem is that WPSes should be able to set background colors internally, much like you can for the menus. Then, if a WPS sets one, it overrides the current backdrop with a solid colour of whatever is set, allowing the clearing of backdrops to white or some other color, and allowing solid-backdrop WPSes to work even when you have a menu backdrop, without having to use a solid bitmap for them.

sure i agree but I don’t remember that happening in the past

petur commented on 2006-05-17 23:30

while trying to fix this:
Additional bug: if you clear the backdrop from within the wps screen, the wps code doesn’t notice the clearing and will restore the old backdrop again whenever leaving the wps…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing