• Status Closed
  • Percent Complete
  • Task Type Patches
  • Category User Interface → Language
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by davinci - 2006-05-15
Last edited by mmohr - 2006-07-30

FS#5364 - "NAVI = Yes" for iRiver H100/H120/H300 (most languages)

No more wrong “PLAY = Yes” in the dialogs. Now “NAVI = Yes” in Eglish and “NAVI = Ja” in German language files.

Closed by  linusnielsen
2006-07-30 19:18
Reason for closing:  Accepted
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Thanks. How about fixing the remaining LANG_BOOKMARK_SELECT_PLAY entries too?

Project Manager

I think it would be better to call it SELECT instead of NAVI. In Rockbox, the joystick button has always been SELECT, and it works for the X5 as well.

But “NAVI” is writen on the button.

Project Manager

Not on the H100, and we’d like to treat both platforms the same.

So why do we have “h100” and “h300” for the language files?

Project Manager

My point is that we want to have a common name for the joystick button on all the joystick targets. Maybe that’s not a good idea, what do you think?

H300 has on itself no joystick. Joystick can be used for more actions than the NAVI button (only press or hold).

And I don’t think that all H300/H100 user own a remote.

Project Manager

Of course. Then it should be NAVI on the H300 at least, like your patch suggests.

Will you add this patch to CVS?

petur commented on 2006-05-23 12:46

and call the h1x0 joystick ‘joystick’

“navi” is written on the h100 on the remote…?

Mike (Falco98) said : “navi” is written on the h100 on the remote…?

Yes, on the H100 remote, the button to go in the browser and in the settings menu is named “NAVI/MENU”.

Little error… Forget the “and in the settings menu” I said in my last comment.

mmohr commented on 2006-07-30 14:04

Here is an updated patch which calls it

"NAVI = yes" for h300 and 
"SELECT = yes" for h100/h120

for all languages except japanese and hebrew
(I’m unable to edit those at my system…)
and afrikaans, bulgarian, romaneste and turkce
(they don’t contain that LANG-ID - are they up to date?)

BTW, there have been a few lanuages (e.g. catala) where
the “NAVI = yes” for h300 is already included in CVS!

Project Manager

After some discussion on IRC, we have come to the conclusion that it should be called “NAVI” on both H100 and H300, since the original iriver manual calls it NAVI.
Care to fix? Then I will commit.

mmohr commented on 2006-07-30 18:34

O.K. here is a version with “NAVI” for both the H100, H120 and H3x0…

BTW, is “PLAY” O.K. for all other targets?
Or would it be better for them to also have a different name for them?


Available keyboard shortcuts


Task Details

Task Editing