Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by David Koster - 2006-05-18

FS#5386 - Long Songs don't seem to work

I played songs with a long playing time (mine was 8 mins) the song skips every few seconds. Strangly enough if i go back into file manager (select button) it doesn’t skip anymore. NMaybe someone could have a look at that.
Thanks a lot,
D-Skyman

Closed by  Steve Bavin
2006-10-02 12:56
Reason for closing:  Invalid
Additional comments about closing:  

The original problem is just down to CPU use. OP has not added any info regarding secondsry (sample rate?) problem and can open a new task for that if required.

Paul Louden commented on 2006-05-18 19:14

Does it not do this with other songs of the same format and bitrate?

Peter D'Hoye commented on 2006-05-18 23:01

use a wps without peakmeters and if needed disable EQ/crossfeed/…. you know, audio tweaking settings

Martin Muchowski commented on 2006-05-19 13:59

It doesn’t seem to be about track length, rather about scrolling any long ID3 Data in wps. I have the same problem on my h320 with a 2:13 track, that has a title so long that it scrolls. Whereas other tracks, longer than 10 minutes and with short titles, that don’t scroll, play fine. All tracks are LAME –aps-encoded. (I’m not giving configuration details, because I just wanted to ppoint out, what causes this. If someone thinks it is necessary to do it anyway, I’ll upload my .cfg)

Martin Muchowski commented on 2006-05-19 14:27

Update: I now know exactly, what causes the stuttering (I know, it’s CPU load, but I mean the cause for it): Scrolling settings. Going up on speed and going down on steps per pixel seems to up the load heavily. I’m sorry if this is a known fact/bug already, just wanted to state it.

David Koster commented on 2006-05-19 15:22

Oh..ok! well…seems as if you know what the problem is. It wasn’t the long ID3 data and it wasn’t the bitrate. I tried other songs with high bitrates and it worked.
So..and i changed around all kinds of sound settings and it still did not work. It know only happens from time to time.

But I found something else. With these songs (tool - 10,000 days) that i had the problems described here I also found that they are played slower than they should be.
Does anybody know why that could be…I’ll try to figure out what is different on those songs from the others.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing