Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System Iriver H300 series
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by bob84123 - 2006-05-21
Last edited by pondlife - 2006-09-26

FS#5408 - iriver h340 hangs on boot

After installing rockbox on my iriver h340, the system hangs at ‘loading firmware’. I’ve used the patched 1.3eu firmware and tried the latest nightly build and also the build from the 16th with the same results.

Closed by  pondlife
2006-10-04 14:10
Reason for closing:  Invalid
Additional comments about closing:  

This seems to be a support issue.

beeg commented on 2006-05-26 14:39

I've got the same problem. I'm using the patched 1.28E firmware with today's build (26th May).

beeg commented on 2006-05-26 14:41

Oh, and in case it makes a difference I'm using H320.

Project Manager

And it still hangs today with the latest daily? And you have a fully charged battery?

Yes, that's correct.

Please recheck if the problem persists.

Retried with the latest daily build, same problem.

Does it still hang if you clear settings by holding REC on startup? There is another bug reported where a missing file can trigger an immediate hang if "resume on startup" is enabled.

Do you mean when I hold Record + Play to start into the iriver firmware? When I do that there are no problems. What is "resume on startup"?
Thanks for looking into the problem.

No, I mean clearing the Rockbox settings:
1) Press Play to start up, until you see the "Rockbox boot loader" heading.
2) Hold Record until you see a message reading "Cleared".

Resume on startup is a setting where Rockbox will resume the last played track automatically when you startup. Might not be your problem, but worth a try.

I can't get the 'cleared' message. I turned the iriver on, got to 'Rockbox boot loader…Version 5…Batt: 3.86V…Loading Firmware',
I held down the Record button for almost a minute and nothing happened. I tried again, holding Record from as soon as I saw 'Rockbox boot loader', but still nothing.

Do you not see anything more after "Loading Firmware"> You should see "Length" next, followed by "Checksum"…

If not, sounds like there is a problem accessing rockbox.iriver. Try a full CHKDSK/SCANDSK/FSCK on your H300 drive, then delete rockbox.iriver and update it again.

If it weren't for the multiple reports, I'd say this is a tech support issue and should be moved to the forum/mailing list/IRC…. but we'll carry on for a while longer. ;-)

Thanks for the advice.. I'm on a linux box so I need to use fsck, but I'm not sure how to actually use it. Do you know how to do it? I'll keep looking in the meanwhile.

Hi Bob, sorry I don't know much about fsck, but you should ask on IRC or the forums.

I'll close this now as it's almost certainly a support issue rather than a bug.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing