FS#5413 - IPOD 5G woud´nt charge

Attached to Project: Rockbox
Opened by Bert Reiner (jeanlucthepicard) - Monday, 22 May 2006, 08:57 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When I put in the power cord, the power icon and a per cent indicate appear in the display, but the IPOD Video would´nt charge. The per cent indicate does not change. Only with the original aplle firmware the ipod would charge. I use the latest CSV from 05 / 21 / 2006. Is there a work around? Thanks a lot. (the best third party firm for the ipod, the sound is outstandingly accurate and full of bass (wow). I never use the terrible apple firm and this impossible itunes soft.)
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Wednesday, 24 May 2006, 13:05 GMT
Reason for closing:  Out of Date
Additional comments about closing:  reporter can\'t reproduce the behaviour anymore.
Comment by Dominik Riebeling (bluebrother) - Monday, 22 May 2006, 09:12 GMT
Please read the FAQ:
Is it *really* not charging or is only nothing displayed?

Also, please read !
Comment by Bert Reiner (jeanlucthepicard) - Monday, 22 May 2006, 09:58 GMT
Hi, no, my IPOD wouldn´t charge in Rockbox mode. The battery icon in the original apple firm shows the same state of charge as in Rockbox firm before charging and after several hours. But I will still test once more and report.
Comment by Dominik Riebeling (bluebrother) - Monday, 22 May 2006, 10:12 GMT
According to the device chart ( the video does its charging control using hardware, so I think it should actually charge. As I don't own a video I can't test it myself.
Comment by Paul Louden (darkkone) - Tuesday, 23 May 2006, 01:21 GMT
Well, it sounds like it _is_ charging, it's just using the same amount as it gains, if the battery doesn't go down either. I think someone said that while charging the iPod only draws 100ma under Rockbox instead of the 500 that it does in the retail software, but I can't verify this. It would explain why it can charge during playback on the lowest power iPods (Nano) and doesn't charge succesfully on the Video.
Comment by Bert Reiner (jeanlucthepicard) - Wednesday, 24 May 2006, 11:33 GMT
Sorry. Something strange. Yesterday I charged my IPOD with Rockbox and it funtion well. No notion, why it did not function at the beginning . Please close this entry. This Firm is ingeniously.