Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To
    Steve Bavin
  • Operating System Iriver H300 series
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Mike Holden - 2006-05-22
Last edited by Steve Bavin - 2006-09-23

FS#5414 - File/dir naming stops at end of playlist

On my iRiver H340, I have voicing of files and dirs switched on, and all voice clips generated. This works fine after booting up, and still works fine during playback if I go to the file browser.

However, once the playlist has finished, file and dir names no longer speak, until I reboot the unit again.

Menu voicing is turned off, if that makes any difference.

This is with a CVS version from a couple of days ago CVS-060517, and many versions before that as well - not sure if it ever worked!

Closed by  Steve Bavin
2006-09-28 10:11
Reason for closing:  Fixed
Mike Holden commented on 2006-07-03 14:10

This bug has gotten worse in the build from 060701. If clips are enabled, the first play operation works correctly. However when you reach the end of the playlist, voicing stops as described above, but in addition, the next play will lock up the device once the first music file is loaded.

This bug ought to be raised to Critical level, since it is a major pain, requiring a hard reset after every play.

Mike Holden commented on 2006-08-29 09:47

Even after various recent voicing fixes, this is still an issue.

Voicing stops after reaching the natural end of a playlist, and further playback freezes requiring a hard reset.

Steve Bavin commented on 2006-08-29 09:50

Hi Mike,

Can you please export your config settings and attach them here - I’ll look into it.

Some other questions:
1) Do you now have your English.voice file in place?
2) What music format(s) are you using?
3) Does this happen when playing back an album (i.e. using a Rockbox-generated playlist), or only when playing an M3U file?
4) Are you using ID3 view at all?

Mike Holden commented on 2006-08-29 10:14

1) Yes I do, but I tested it with and without the voice file, and both ways fail.
2) mp3, 128kbs
3) I use externally generated m3u files. I haven’t tested other playlist methods such as playing a folder or generating a playlist on rockbox.
4) No.

Steve Bavin commented on 2006-08-29 10:28

Thanks Mike, I managed to reproduce this but had to change your settings from “repeat: all” to “repeat: none” to make it stop playback automatically. Is this right?

Mike Holden commented on 2006-08-29 10:34

Repeat setting isn’t a part of the issue, AFAIK, so this is fine, yes. I was listening to a repeat playback recently, so this is not my normal setting!

David Bennett commented on 2006-08-30 08:15

Similar thing is happening on iPod Nano. Occurs after last song in a folder has played.

Steve Bavin commented on 2006-09-14 17:48

Hi Mike,

I’ve had a stab at fixing this, but it wasn’t a simple mod. There’s a patch at http://www.rockbox.org/tracker/5992 if you’re able to try it. Leave any reports on that Flyspray entry.

I’ve noticed that your other report - where CPU stays boosted on stop - is still an issue, but I think I know what’s causing this now and will update the patch next week.

Steve Bavin commented on 2006-09-18 11:24

Hi Mike,

This should now be fixed in CVS - please download a build and give it a go! I’ll close this bug if I don’t hear back from you.

Steve Bavin commented on 2006-09-18 12:06

Hi Mike - actually this was fixed but it broke recording and has now been reverted. I’ll carry on looking into it though.

Steve Bavin commented on 2006-09-19 09:02
Steve Bavin commented on 2006-09-26 07:54

Fix for this is now in CVS - please test and report back.

Mike Holden commented on 2006-09-28 10:06

Fixed. Thanks

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing