Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Critical
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Douglas Valentine - 2006-05-26

FS#5434 - Opening a text file with the Text viewer plugin locks up H140 player.

Steps to reproduce.
1. boot player and hold down record to reset to default config.
2. press select and open a text file from the directory view.
At this stage the player will lockup and require you to press the reset button and on next boot the player boots into the manufactures stock firmware not Rockbox.

Closed by  Jonathan Gordon
2006-07-16 14:44
Reason for closing:  Fixed
Additional comments about closing:  

looks like its working, we can close :D

Paul Louden commented on 2006-05-26 18:30

This is running a new copy of Rockbox on a fresh install. I remember we had a problem like this a few weeks back, but it was fixed, so could you verify that after fully deleting your rockbox install, and putting a fresh bleeding edge build on it still happens for you, and that it happens with multiple text files?

Douglas Valentine commented on 2006-05-26 18:38

Yes this is on a fresh CVS bleeding edge install after deleteing the .rockbox folder.

I have also tested with more than one file at least one of which I have previously viewed with an older CVS build.

Jonathan Gordon commented on 2006-05-27 08:59

can you upload one fo the files that was crashig it?

Douglas Valentine commented on 2006-05-27 13:00

yes no problem.

Jonathan Gordon commented on 2006-05-27 14:02

well ull be glad (?) to know that it crashed the sim here which means its actually a bug… time to investigate..

Alistair Marshall commented on 2006-05-28 15:03

could this be related to  FS#5187  ?

jerry lange commented on 2006-06-18 06:34

i am also having this problem. i didnt know there was a problem with all files loaded in the text viewer. i am trying to view a .m3u file and that also crashes the player

Mitchell Jareo commented on 2006-06-22 03:21

I'm having this problem too. Playing around with this makes me feel that if the first character in the file is whitespace, rockbox locks up.

Marc Flint commented on 2006-06-23 03:21

the same problem occurs on h-320 devices using recent rb builds. replacing the current version of viewer.rock with ones from older builds (e.g., rockbox-h300-20060510 works fine) fixes this problem.

since the viewer seems to crash more frequently when files using a "layout" (like .nfo files or the .txt douglas posted) are involved, i assume that it might have to do something with numerous blank spaces and/or special characters.

Mark Arigo commented on 2006-07-13 20:21

I didn't notice this bug report until I filed my own.
http://www.rockbox.org/tracker/task/5658 I included a patch to fix the bug.

jerry lange commented on 2006-07-13 20:31

[quote]At this stage the player will lockup and require you to press the reset button and on next boot the player boots into the manufactures stock firmware not Rockbox.[/quote]
one way to turn on the player on with rockbox after a restart is to put the hold button on and then press play. the hold screen will pop up (either iriver or rockboxs screen) and then take off hold wait a few seconds and then turn it on again.

Douglas Valentine commented on 2006-07-16 11:14

@Mark
The version of your patch committed to CVS fixes the problem and all the text files I have tested now open and view without problems thanks.

@jerry
Thanks for the information.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing