Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To
    pondlife
  • Operating System Iriver H300 series
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by mikeholden - 2006-06-08
Last edited by pondlife - 2006-09-23

FS#5520 - Cpu stays boosted on stop

With a recent daily build CVS-060526, I have noticed that the Debug→CPU Frequency and Audio Thread screens both show the CPU as 100% boosted to 124Mhz after playing music (mp3) then pressing STOP. During normal playback, and before playinmg music after switching on, the CPU shows 0% boost 24Mhz. THis seems to stay at 100% for a long time, probably for ever. If I start to play music again the frequency returns to normal again.

Could this be related to the apparent battery problems on iRiver 300?

Closed by  pondlife
2006-09-28 09:55
Reason for closing:  Fixed
Additional comments about closing:  

All ok now.

Can you reproduce this in an actual new build? I notice that you reported this today while using a build nearly two weeks old.

Also, can you provide more exact steps for reproducing it with a current build?

Just loaded the curernt daily build, and the issue is still there.

Simple steps to reproduce:

Boot up, play a file (mp3 in this case), let it run for a few seconds, press stop, check cpu frequency in debug screens.

petur commented on 2006-06-15 21:00

Sorry, unable to reproduce at all.
Used an mp3 file, tried with and without (menu) voicing.

Can you check cpu freq stays high? Maybe there’s something running in the background? (dircache/tagcache)?

The battery consumption problem has been identified as the usbotg chip not being powered down and thus consuming lots of energy.

I have reset the settings to default. I have a voice file loaded (english.voice). The problem is still easy to reproduce.

I can upload my .rockbox dir and an mp3 file that show the issue if necessary, just in case it’s something specific to my unit, but since I how have a default config it seems unlikely.

petur commented on 2006-06-16 19:09

mp3 file I doubt, but maybe the voice file matters… where did you get it?

It’s one of the voice files from the official Rockbox site.

Looks like it could well be voice related.

With default settings, if I rename the voice file so it doesn’t load, the problem goes away.

My usual settings have voiced menus turned off, but file and dir clip voicing on. Disabling file and dir clips the problem goes away.

I.e. in both cases, if voicing of everything is switched off, the problem goes away. If voicing is switched on, the cpu stays boosted after I press STOP.

I wonder if there is any connection with another bug I reported a while ago, which currently has received no additional comments, regarding voices stopping working at the end of a playlist? http://www.rockbox.org/tracker/task/5414 which I consider to be a reasonably serious bug, especially for blind users or users who use their unit in a car or other place where file voicing is important.

After recent fixes in voicing, I revisited this to see if it has been fixed by other changes, but unfortunately it is still an issue.

Hi Mike, I believe I’ve fixed this (and the other voice crash you reported). It’s not in CVS yet (needs more testing) but you can get an H300 build from http://pondlife.homeip.net/images/rockbox.zip .

Fix for this is now in CVS - please test and report back.

Yes, fixed. Thanks Steve

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing