FS#5618 - Resume Function Unresponsive

Attached to Project: Rockbox
Opened by Doug Keidel (rbotboy) - Thursday, 29 June 2006, 16:16 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have the latest build 6-29-2006. When turning on the player it boots and then the file tree/Music Folder/Video Folder etc. shows. I press play to resume playback and no response. I wait a few seconds press the play key again and nothing. Around the third time of trying the resume playback function starts. Alot of times if I highlight the music folder and press play the resume playback function will work. If the rockbox folder is highlighted it usually takes three or so times before the resume playback will function properly. I have never had this problem before with the resume playback feature. Thank you for your help.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Thursday, 29 June 2006, 21:45 GMT
Reason for closing:  Invalid
Additional comments about closing:  not a bug.

\"First keypress enables backlight\" is enabled per default. I\'m unhappy with that default setting as it causes confusion again and again (but I don\'t have the power (tm) to change the default). Please also see the manual first when expecting strange behaviour -- rockbox is a bit different from its point of view than most other players.
Comment by Dominik Riebeling (bluebrother) - Thursday, 29 June 2006, 16:21 GMT
have you enabled the "First Keypress Enables Backlight" option? (General Settings / Display / LCD Settings)

Please search for help in the usual support channels (IRC / forums / mailing lists) before submitting a bug! I don't think this is a bug here ...
Comment by Doug Keidel (rbotboy) - Thursday, 29 June 2006, 21:14 GMT
"First Keypress enables backlight" is set to "yes" I cleared the settings and tried it again with just the Rockbox_default theme and the resume playback starts instantly. I then switched to the iCatcher theme without shutting down and the resume function started on first key play keypress. I then shut down the player and re-started with iCatcher theme and it started instantly. Ok I don't know what has happened. It seems to be working fine now. I guess clearing the settings helped. Sorry for any inconvenience.