Rockbox

  • Status Closed
  • Percent Complete
    0%
  • Task Type Feature Requests
  • Category User Interface
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Steve McKay - 2006-07-13
Last edited by Marc Guay - 2008-04-17

FS#5655 - Recall Database browsing location/directory on resume

This was requested here (http://www.rockbox.org/tracker/task/645) some time ago (3 and a half years actually!) and was requested specifically for Archos, so I thought I’d put in a more recent and general request.

The option to resume playback on a restart is fantastic, but it would be great if Rockbox could also remember the Tagcache location or directory for the file being resumed.

Not sure how much sense that makes, so I thought I’d clarify. Currently if you resume playback, the album or playlist in question continues playing, but if you hit select (to use an ipod example) to browse the ID3 library (or the folders using the all files view option) it starts at the base folder or at the ‘artists, albums etc’ level rather than jumping to the folder or album containing the file currently being played as it would if the file/album/playlist had just been selected.

Closed by  Björn Stenberg

Reason for closing:  Fixed
Additional comments about closing:  

Closing all feature requests.

Dominik Riebeling commented on 2006-07-13 06:29

for the file browser view, enable the “follow playlist” option to start in the last used folder when “resume on startup” is enabled.
For tagcache this would be harder, as you can access a song in various ways (e.g. by browsing the artist, then the album or searching for the title or by browsing all titles …) so I don’t think this would be feasible - it would require saving the complete search path. Also, I consider tagcache as a database that is used to generate a playlist from searching for files which makes it somewhat useless to start the database view in the same state. When I want to play albums I use the file browser view which is much easier IMO.

Steve McKay commented on 2006-07-13 08:36

Fair call. I guess it depends on how you use Rockbox. Personally, I don’t use file browser view, and only listen to albums. If we ignore the dynamic nature of the tagcache database (ie search options) though, and consider it a simple hierarchical list with the path: Artist –> Album –> Track, I would imagine that would be a fairly simple path to save. This is pretty much all I’m after. But as I say, it depends how you use Rockbox, and clearly there are plenty of people for whom this isn’t an issue.

Paul Louden commented on 2006-07-15 05:40

The problem is that you can’t ignore the dynamic nature of TagCache, even the hierarchy is actual a series of filters/searches, they’re just static searches.

I mean, even with your suggestion, songs can be found in Genre→Artist→Album→Track, Artist→Album→Track, Album→Track, and just Track. And some songs may not have an Album, which means they wouldn’t show up in all of those. Which one has priority if the song shows up in more than one? How do you deal with modified TagNavi.config files? I have one that has a filter for songs whose titles contain a specific word, which means there’s a duplicate of every one of those songs in that category as well, and so on.

All of TagCache is really non-static because of how the TagNavi.config file is used.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing