• Status Closed
  • Percent Complete
  • Task Type Patches
  • Category User Interface → Language
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by CreativePony - 2006-07-15
Last edited by jdgordon - 2006-07-15

FS#5665 - patch for english.lang bug in iriver players yes/no screen

I’ve never contributed to rockbox before, but I’ve compiled this and it works fine on my h140, its fixing a bug where the Select button activates the Yes command in yes/no screen’s, while without this patch, the latest build (not cvs) would display a message saying that the PLAY button would do this, which would actually activate No

I hope I’ve done this diff/patch thingy right, as I’ve never made one before

Closed by  mmohr
2006-07-30 14:12
Reason for closing:  Duplicate
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Seems to be the same patch as
 FS#5364  — \"NAVI = Yes\" for H300 / \"SELECT = Yes\" for H100/H120 (most languages)
so I closed this one here…

Added another change by request from jdGordon, changing it to NAVI on h300's instead of PLAY also.. I haven't recompiled to test this, but it should be fine?

Well, technically the key should be called "NAVI" on H100/120s as well.

Out of curiosity (since my remote is broken) is it the NAVI key on the remote as well?

This is what I thought.. I have a US h140 and its always officially been called NAVI to me.. from all the confusion about, I wonder if maybe the European models call it SELECT? On my h140 remove, there is a 'NAVI / MENU' action in pressing down the top left wheel thing..

Personally I don't mind much, select seems like a nicer name anyway, and if we change it here, it would need to be updated in a LOT of other places too (especially the h120/140 manual)

er, thats supposed to read "On my h140 remote, […]"

I've looked up the Eauropean h140 manual through the iRiver website.. It calls the button NAVI too..

CreativePony, updating the name in the manual will be a piece of cake as we have heavily macrofied it :)
For the naming discussion, I own a EU H120, and I'm pretty much used to that key as "select" – mainly because I usually dont use the remote (which labels it as "Navi / Menu" on my device as well, so it seems to be identical for EU and US models).
As the button isn't labelled at all on the device I'd personally prefer using "select" as it seems more natural to me. But as the remote calls it "navi" maybe we should consider renaming it to "navi". Another option would be to name this fact for the remote in the manual when we manage to write a section about the h100 remote.

I'd actually be happier calling the key "Select" universally, and then noting in an early section of the manual (maybe a "Basic notes for migrating from the retail firmware" or something) noting that the NAVI button is referred to as Select as well in Rockbox.

Since we use Select to identify the center button on the iPod, as well as it probably being useful for the generic "Invoke" button on any future players that might have one, it keeps it a bit more consistent across targets too.

I like that idea too.. it would be nice because someone with an iRiver can tell someone with an iPod which buttons to press on their iPod or Archos or whatever they may have.. The downside is units that explicitly label the button, like the h300..

ive fixed the patch up so it will (hopefully) work automatically with my web compiler thingy

just putting a note here to hold off commiting this for a bit.. (not that its really needed :p )
if my button changes get introduced the iviers will be using on for this screen so this wont be needed.


Available keyboard shortcuts


Task Details

Task Editing