Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System All players
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by deltron - 2006-07-19
Last edited by obo - 2007-08-24

FS#5683 - iPod video locks up when scrolling in file list

I am scrolling in my list of songs, which I store in /music, and the iPod always locks up at the same folder as I am trying to browse past it. It locks up right before the problem folder, which is 69 characters long. The folder name contained alphanumeric characters in addition to the &, ‘, and () characters. I renamed the folder to just the artist name, with the album in a subfolder, and it was then able to scroll past that folder. The folder name is “jello biafra & the melvins - never breathe what you can’t see (2004)”. I’m using the daily build from 19 July 07. I am attaching my directory listing of my music directory for reference (don’t blame me for my musical taste :P)

   dir.txt (6.1 KiB)
Closed by  obo
2007-08-24 22:23
Reason for closing:  Works For Me
Additional comments about closing:  

Can't reproduce this with a current build - request a re-open if this is still an issue.

19th July 07 - impressive. That won’t be built for several months yet!

My guess is the apostrophe character is the one causing the problem. Can you try just replacing that character with another to see if you can reproduce? That way we can easily narrow down exactly which character is the problem, or is it the length (although that also should be ok). Brackets should be ok, as I have some of them on my h340, and ampersand is also ok because I have some of them in my file and folder names as well.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing