Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Prashant Singh Pawar - 2006-08-10

FS#5788 - Problem with Rockbox when Battery runs out completely

I was using my iPod video’s Apple firmware, and watching some mp4 videos, during this the battery of my ipod ran out completely, Apple’s firmware gave me a warning and shut itself down.

I use AC charger for charging ipods(I don’t have computer at home, I Guess that’s the whole point of using an ipod), but the problem was that as soon as I was putting it on charge, it started booting itself, and rockbox got loaded, and during loading it used enough battery that it ran out of battery again and restarted, this kept on happening in infinite loop.

I sometimes even tried to boot to apple’s firmware, but same thing happened, it got restarted(and then again I had to choose between Rockbox and apple).

I don’t really know what is the solution for this problem, finally I got my ipod to charge itself by connecting to a comp at office(I guess when comp is connected it uses less power).

I wanna know if anything can be done about it, maybe some lesser battery mode be made which can detect if AC charger is connected(it can be done, apple’s firmware differentiate when AC charger is plugged in and when iPod is charging from USB).

Another thing, since I was facing this problem on Apple’s firmware also so I think some Apple-only user must have posted a similar bug on Apple’s site, if nobody gets that error that means its only there when you install rockbox with Apple.

Closed by  Barry Wardell
2007-03-24 01:06
Reason for closing:  Not a Bug
Additional comments about closing:  

This is a problem with Apple OS, not with Rockbox.

Paolo Rassi commented on 2006-09-13 15:37

The same happened to me some time ago with a new Video/5G/60GB Ipod (Rockbox was NOT in the ipod). I was listening mp3 music files with the Apple firmware when the battery run out. The AC charger did not work any more. The only solution was to recharge the ipod with a computer. So i think it is not a Rockbox problem, but an Apple problem.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing