Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System SW-codec
  • Severity Medium
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Rincewind - 2006-08-11
Last edited by nicolas_p - 2008-01-09

FS#5797 - Codec failure with directory skip when in file browser

When automatic directory change is enabled and the player is in the file browser when the dir skip is about to happen, rockbox fails to load the next track (in the next folder). Instead there is a splash “codec failure” and rockbox tries to load different files but fails there, too and so on.

Steps to get this bug:

1. Enable automatic directory change
2. Play the last file in a directory (this also happens if the last file is reached “naturally”)
3. When the file plays, enter the browser by pressing Navi, but don’t select a new file
4. When playing file ends, the disc spins up and tries to load the first song in the next folder but it is not starting, instead I get the splash “codec failure!” or “can’t load codec”. Then Rockbox tries to load a different file and fails again and so on. If you enter the wps when this is happening (by pressing PLAY) the WPS says “No file!”

Eventually Rockbox continues playing if you enter the wps again with PLAY, but many folders/files down.

Crossfade on/off doesn’t have an effect.
Tested by me on H120, stripwax got the bug on ipod 5g

Closed by  nicolas_p
2008-01-09 20:37
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in r16039.

Also tested with same result on .ogg files

See this thread from this point for discussion:

http://forums.rockbox.org/index.php?topic=5018.msg44592#msg44592

More Tests by me. It has something to do with dir cache. More details + logf can be found here:
http://forums.rockbox.org/index.php?topic=5018.msg44699#msg44699

Hi Simon,

Has this been fixed now? I suspect it has. Please can you retest with a CVS build and report back.

I don’t have a build environment ready at the moment, If I get Linux running again I’ll try and report.

Hi Simon,

No need for a build environment, just download a current build from http://www.rockbox.org/cvs.shtml

Unfortunately, the bug still exists. I tried with a fresh unpatched cvs build. And it doesn’t have something to do with dircache. I get this bug with default settings except “auto change directory: on” and “Repeat: off”

just tried this twice on my sansa and couldnt reproduce.
edit: woops, definatly a dircache issue…

It’s likely still in there - stripwax showed it to us at DevConPub2 last week.

obo commented on 2007-07-30 11:22

I can only reproduce this with dircache enabled.

I can reproduce it in my iAudio X5V (I have dircache enabled, so…). I’m using 13968-070724.

I was able to reproduce this problem easily in r15698.

I’ve been able to reproduce again on target (Gigabeat), but not in the sim. Has anyone managed to reproduce in the sim?

I have tried to reproduce it on the (H120) sim and on my sansa. It didn’t occcur on either so I think it is dircache related.
I haven’t updated my H120 for ages, but I just tried it on H120 target without dircache and the bug didn’t happen (with dircache enabled it does happen). If anyone wants to debug this it is most likely in the dircache code somewhere… If it is possible to enable dircache in the sim it might help to use GDB for debugging. I haven’t tried this, yet.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing