Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category LCD
  • Assigned To No-one
  • Operating System iAudio X5
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by madcow - 2006-08-11

FS#5800 - LCD-sleep awake bug

After awaking from sleep the screens contrast isn’t right (way too dark,).

Closed by  MikeS
2006-09-26 22:25
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

This problem is fixed.

Please describe all your non-default settings’ values.

These are my settings before I installed the build with LCD-sleep but they should be identical (without ofcourse the LCD-sleep value).
I don’t really know my non-default values so I just send all of them.

I just tried to set brightness=8 contrast=13 as you have and I could not reproduce your problem.

BTW,
contrast=13 seems very low to me… I use 22.

Well that’s strange!
Are you sure you waited long enough for the display to go to sleep.
Try when returning from sleep to change the contrast (when set to a lower value).
It will pop back to the actual contrast (so you notice).

OK, confirmed.
This should be fixed by calling lcd_set_contrast() upon LCD wakeup.

MikeS commented on 2006-09-26 21:56

Don’t know if that’s the best. I’ll just cache the contrast in the driver like it should be done. Should be ready in 10!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing