Rockbox

Tasklist

FS#5825 - text_editor plugin segfaults on h1xx

Attached to Project: Rockbox
Opened by Jochen Kemnade (jk) - Wednesday, 16 August 2006, 09:10 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

the text_editor plugin segfaults, on the player as well as in the simulator. to reproduce the crash, take the following steps:
open the text_editor via the plugins menu and move the joystick into an arbitrary direction.

a backtrace of the simulator crash looks like that:

0x0808a3fc in utf8length (utf8=0x8 <Address 0x8 out of bounds>)
at common/unicode.c:240
240 while (*utf8 != 0)
(gdb) backtrace
#0 0x0808a3fc in utf8length (utf8=0x8 <Address 0x8 out of bounds>)
at common/unicode.c:240
#1 0x0808e6d1 in bidi_l2v (str=0x8 <Address 0x8 out of bounds>, orientation=1)
at bidi.c:133
#2 0x08091454 in lcd_remote_putsxyofs (x=60, y=0, ofs=0,
str=0x8 <Address 0x8 out of bounds>) at drivers/lcd-h100-remote.c:1166
#3 0x08091540 in lcd_remote_putsxy (x=60, y=0,
str=0x8 <Address 0x8 out of bounds>) at drivers/lcd-h100-remote.c:1195
#4 0x0806a3d8 in gui_list_draw (gui_list=0xb72c6dbc) at gui/list.c:318
#5 0x0806aa62 in gui_synclist_draw (lists=0xb72c6d88) at gui/list.c:592
#6 0xb2285829 in plugin_start (api=0x809cde0, parameter=0x0)
at text_editor.c:397
#7 0x08057ca3 in plugin_load (
plugin=0xb72c6e84 "/.rockbox/rocks/text_editor.rock", parameter=0x0)
at plugin.c:587
#8 0x08064048 in ft_enter (c=0x812eb00) at filetree.c:543
#9 0x0805f80f in dirbrowse () at tree.c:612
#10 0x080605a8 in rockbox_browse (root=0x809c971 "/.rockbox/rocks",
dirfilter=13) at tree.c:1161
#11 0x0804d6a0 in plugin_browse () at main_menu.c:278
#12 0x0804dcf6 in menu_run (m=0) at menu.c:183
#13 0x0804d8f0 in main_menu () at main_menu.c:403
#14 0x0805f952 in dirbrowse () at tree.c:684
#15 0x0805f015 in browse_root () at tree.c:260
#16 0x0804ce60 in app_main () at main.c:109
#17 0x080991cb in sim_app_main (param=0x0) at uisdl.c:185 etc...
This task depends upon

Closed by  Peter D'Hoye (petur)
Thursday, 17 August 2006, 11:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  no details on what/who fixed this
Comment by Dan Everton (safetydan) - Wednesday, 16 August 2006, 10:08 GMT
That stack trace looks like it's caused by the new list titles, but I can't reproduce this issue. Either in the sim or on my H120. Any chance you could try this again with the latest CVS?
Comment by Jochen Kemnade (jk) - Wednesday, 16 August 2006, 10:14 GMT
this trace is from the latest cvs. and i don't think it has something to do with the list titles, because i also expierienced that crash some weeks ago.
Comment by Dan Everton (safetydan) - Wednesday, 16 August 2006, 10:23 GMT
Okay, the reason I say it was related to the titles is that strack trace goes right through the list title code. Odd. Maybe something in the text editor plugin is trashing memory. Someone else will have to look at this as I can't reproduce it.
Comment by Jochen Kemnade (jk) - Wednesday, 16 August 2006, 11:50 GMT
oops, my mistake, i just tried it again with a 20060814 version and at least in the sim it works fine. so the crash that happend a few weeks ago seems to have been caused by something else, which is fixed now.

Loading...