Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System iPod 4G Grayscale
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by MarkGaleck - 2006-08-16
Last edited by dreamlayers - 2009-04-19

FS#5826 - no "charger status" in iPod 4g Gray

The manual for Rockbox for iPod 4th generation Grayscale iPod, says there is “charger status” on the status bar, between batt and volume indicators. I see no such thing. There is only empty space, however, I know the iPod is charging because the numeric battery indicator goes slowly and steadily up.

I am a new user of the software so please excuse if I am misunderstanding something, but I did read the manual and downloaded the latest build (2006-08-16) and checked the database for this bug.

Closed by  dreamlayers
2009-04-19 18:31
Reason for closing:  Fixed
Additional comments about closing:  

Status bar issue fixed in r12169. USB power detection added in r20745.

This is working fine on the Sansa e200 w/ r16890. Is it specific to the iPod 4G or out of date?

I’m pretty sure this bug can be closed. I grabbed the build for this model on March 23, 2009, version r20492-090323, and can confirm that there is an icon between the battery and volume indicators in the status bar when the USB cable is plugged in. I’m unsure whether the icon is supposed to do beside show up when the device is connected to the computer, but it’s there.

In power_input_status() in power-ipod.c, the 4G iPod detects FireWire power, but not USB power. The status bar shows the plug because the same pin is detected in usb-fw-pp502x.c, and that is reported via usb_connected() returning true. Right now I’m not sure if there are any consequences from not detecting USB in power_input_status().

I think there might be at least one consequence from not detecting USB power in power_input_status(): Connect USB while holding MENU, so you don’t go into the USB screen. Then try to turn off the iPod. It may attempt to turn off. Then after Rockbox shuts down, the iPod would probably start up again because USB is connected.

The attached patch adds this detection. If the iPod tried to turn off in the earlier test, try again with the patch.

Tried this on mini2g and it seems to work fine:
- a connected usb charger gets reported both in the battery debug screen and the Rockbox Info menu
- if a usb power-only connection was established the Ipod doesn’t shut down when holding Play
- on a charger connection the Ipod doesn’t shut down.

bluebrother, did you try those things with or without the 4G_photo_mini_usb_power.patch?

I’m confused by what you said about the battery debug screen. Only Nano and 5G iPods have the battery debug screen section which reports if a USB charger is present. When the Rockbox Info screen says “Charging” that is different. It detects charging rather than the presence of USB power. When the battery is full, it shouldn’t say “Charging” anymore.

I tried with the patch. In my case the battery wasn’t charged completely. In detail:

a. stock Rockbox svn, no patches applied.

1. Connect usb with Menu held. A power-only connection is made. The Debug / View Battery screen shows "Charger: absent". The System / Rockbox Info screen shows "Batt: Charging".
2. Connect a usb wall charger. Same as in 1.

b. stock Rockbox svn with your patch applied.

1. Connect usb with Menu held. Power-only connection is made. Debug / View Battery shows "Charger: present", System / Rockbox Info shows "Batt: Charging".
2. Try to shutdown the player by holding Play. Nothing happens (i.e. Rockbox doesn't shut down as expected).
3. Connect a usb wall charger. Same as 1. again.
4. Try to shutdown again. Same as 2.

Hope this clears this up :)

Thanks bluebrother :)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing