Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by mooch - 2006-08-16

FS#5828 - Plugging the charger on an empty iPod starts a cycle of resets

When I plug a charger on an empty iPod, the device starts a cycle of resets when entering charging mode.

The cycle can be interrupted in two cases:

- it has enough battery to load the original firmware and starts the loading of battery
- it has enough battery to load rockbox and one can, by pressing MENU, plug the recharger

There seems to be a serious problem with this, since it is not nice to see/hear the disk making a terrible noise when it resets itself and reloads the firmware.

Closed by  nls
2007-04-15 22:41
Reason for closing:  Out of Date
Additional comments about closing:  

no response from reporter

I’ve got the same problem, no idea what’s causing it. The only way I could stop it was booting into the original firmware then letting it charge from there.

I can confirm this on my IPod 5.5g 30gb video as well. Switching to the apple firmware fixes the problem.

nls commented on 2007-02-17 08:25

Does this still happend with a current build?
There were recently some changes to the USB handling to prevent this.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing