FS#5854 - playback won't resume after ff/rew on iriver remote

Attached to Project: Rockbox
Opened by Tom Yates (TomYates) - Saturday, 19 August 2006, 09:12 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


on an iriver H120D, using the 20060818 firmware, ff/rew doesn't work properly on the remote.

specifically, when i move the remote switch marked "|<< >>|" to left or right and hold it there (rewind and ff respectively), the track progress indicator moves back/forward as if i were rew/ff'ing inside the track, but when i release the switch, the LCD continues to show << or >>, and playback does not resume.

i can workaround it by holding the main unit joystick left or right, to do a little more rew or ff; playback resumes when the main joystick is released.

if i can give any more information, or test fixes, please let me know; i apologise for not being enough of a coder to fix it myself!
This task depends upon

Closed by  Paul Louden (darkkone)
Sunday, 20 August 2006, 19:39 GMT
Reason for closing:  Fixed
Comment by Tom Yates (TomYates) - Saturday, 19 August 2006, 09:14 GMT
should have added: this is while playing back oggs, without playlist enabled.
Comment by Paul Louden (darkkone) - Sunday, 20 August 2006, 05:34 GMT
This should be fixed already, I think. Try with a bleeding edge (not daily) build and see if this is still happening.
Comment by Tom Yates (TomYates) - Sunday, 20 August 2006, 17:44 GMT
not sure about bleeding-edge builds, but i have just loaded the 20060820 daily build, and the problem has gone. you guys rock! i'd close this bug if i knew how to, but it's not clear to me how to do that. sorry.