Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Infrastructure → Build environment
  • Assigned To
    barrywardell
  • Operating System iPod 4G Grayscale
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by lunacymaze - 2006-08-27
Last edited by barrywardell - 2006-09-30

FS#5890 - Target tree architecture for iPod 4G Grayscale

Use the target tree architecture to build the iPod 4G Grayscale firmware.

It would be great to do it for the other iPods, and I could do it but I can only test on an iPod 4G Grayscale.

Closed by  barrywardell
2006-10-05 14:52
Reason for closing:  Accepted
Additional comments about closing:  

Most recent patch committed to CVS.

I’ve expanded greatly upon this patch and moved all iPods to the target tree. All iPod targets build, and I have tested the Color/Photo build on an actual iPod without any noticable problems. Can others please test this on other models?

There is some code duplication, particularly in ipod4g_button_read(), and quite a lot of #ifdef’s in the Rockbox code, but this is a start at least.

I missed a couple of changes in my last patch. Here’s an updated one which should compile OK.

Updated again. Moved the common 4g button code into a single file.

Looks like I missed a load of files in the last patch. Hopefully this one will work.

Added DEFAULT_CONTRAST_SETTING for grayscale ipods which was stopping them from compiling.

Updated patch. Renamed apple directory to ipod. Combined all the common backlight and power code into files shared between models. No need for most of the model specific subdirs any more, so remove them.

dan_a commented on 2006-10-04 18:05

I can confirm that this patch works with a 3G iPod

obo commented on 2006-10-04 18:32

And also a 5G.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing