• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System iPod Mini
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by MrHorus - 2006-08-31

FS#5912 - Only WAV and MP3 playing back

My iPod mini 1g seems not to play back anything other than MP3 or WAV.

The unit works previously and following a crash, I updated the latest firmware using Apple Updater to reflash the unit.

Following this, I reinstalled the rockbox firmware and the latest nightly but found that nothing would playback apart from MP3 and WAV.

Having noticed this, I tried with the latest nightly build 20060831 and again, WMA and OGG(Vorbis) will not play but MP3 and WAV will.

Closed by  bluebrother
2006-09-03 16:54
Reason for closing:  Duplicate
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

The problem discussed is actually caused by a broken file. To make it cleaner I\'m closing this one and opening a new feature request not to fail badly on that kind of broken files – see  FS#5933 

Rockbox does not support WMA, so this is not a surprise.

What do you mean when you say OGG will not play? What happens when you try? Have these specific files worked previously?

It may be that I have copied over MP3 files rather than WMA in the past so that may be the confusion with those.

As far as can see, when I try and play OGG the unit just shows "root" and will not start playing.

These *particular* files have not been tested before but I *have* definatly had Ogg playing before, FLAC too.

I will encode some FLAC content when I get home and test it but are there any troubleshooting steps or things I can try?

Does the player freeze (needing a reset) when you attempt to play an OGG file, or does it just not respond?

Which program have you used to create the OGG file?

The player does not freeze completely.
I can navigate through the menus after attempting to play the files but no other files can be
played unless I reset the unit.

When I attempt to play other files (an MP3 for example), the ID3 tags are read and the unit knows what bit rate the stream is but playback does not start and the time counter stays static - "0:00/3:13" for example.

The files were ripped by Grip but unfortunatly I cannot recall which encoder was used to do the encoding but since I run Kubuntu I presume it would be whatever the default Ogg Vorbis encoder is.

Have you tried upgrading to the latest version of Rockbox? Make sure you overwrite all old files (especially codec files and rockbox.ipod).

Yes, I installed the latest nightly build this morning.

In addition, I will try from CVS when I get home later.

has grip added id3 tags to ogg files? Ogg files should have Vorbis Comments, not id3 tags (which seems to be handled wrongly by grip). There was a similar issue with ogg files that had id3 tags in it, IIRC this was discussed in the forums. If this is your case remove the id3 tags as using id3 tags in ogg is wrong and will cause a playback failure.

I just tried the latest nightly again and they are still failing to play in Rockbox.

If I load the files directly into XMMS and play them off the iPod's drive then they playback perfectly and if I click on "File Info" it shows it as an "Ogg Vorbis Tag" rather than ID3 or ID3v2.

Could you make one of these files available in one way or another?


A friend has confirmed that the file doesn't play in Winamp *at all* but that the file starts with "ID3" so it does appear likely that it may have had ID3 tags applied to it somehow but i'm not really familiar enough with that side of things to say why it would be showing up in XMMS as an Ogg Vorbis Tag.

I'm ripping a CD to FLAC right now to test if they playback or not and I have made sure to untick any boxes that add ID3 tags automatically as it's possible that's what happened before and would be causing the problems like you stated previously although since that's the default settings for Grip I don't see why the files that I ripped previously were working but these new ones are not.

Unfortunatly I don't have the previous files avaliable since they were wiped when I had to reflash the Apple firmware.

The file contains a ID3v2 tag at the very beginning, then Ogg headers, then Vorbiscomments.

XMMS must be skipping the ID3v2 tag. If anything, this should be downgraded to a feature request for skipping ID3v2 tags on vorbis files. If not that, completely closed.

That file has ID3 tags.

This is broken from the specification, meaning that Ogg files must _not_ have ID3 tags. Even mplayer (who plays about everything) fails on playing that file. Remove the ID3 tags (on linux, you can do so by running "id3v2 -D <file>") and it plays fine.

Well that's that one cleared up.

Probably best downgrade to a feature request as whilst it doesn't follow the specification it still shouldn't kill the player and it should be able to detect this and handle it.


Available keyboard shortcuts


Task Details

Task Editing