Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by ecox - 2006-09-02
Last edited by bagder - 2011-06-04

FS#5930 - Battery display incorrect when H120 is plugged in

CVS build 060902
When battery is fully charged (green LED goes off on player), WPS shows battery at 84%, and esitmates 1H 31M left. When unplugged, WPS shows battery at 100% and 27H 30M left.

Closed by  bagder
2011-06-04 21:14
Reason for closing:  Out of Date
Additional comments about closing:  

Unimportant bug and very very old

This behaviour is caused by unability to detect the charging state from the software. The hardware provides only pluggeg/unplugged detection but you cannot simply detect end of charging.

This can be probably circumvented by detecting the battery voltage drop after the end of charging.

To lower your expectations: It is not probably very easy to implement and this “bug” is not probably very important.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing