• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Remote
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 2
  • Private
Attached to Project: Rockbox
Opened by emorockernerd - 2006-09-04
Last edited by pixelma - 2007-12-19

FS#5937 - Missing info / screen corruption on H1x0 RWPS using iAmp theme

There appears to be missing info on H1x0 RWPS using the iAmp theme. I am using a H140. The RWPS is fine using CVS build from 24/08/2006 but something seems to have happened since that date. I suspect it could be do to with the driver for the LCD remote as the pixels bottom right of the screen appear to flicker and not display text. Normally the count of songs in the playlist/folder appears here. I am happy to test if someone attempts to fix this. Rich :)

Closed by  pixelma
2007-12-19 09:04
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Closing it now because: judged from the sim it seems fixed and I got no negative answer - if not, feel free to request a reopen. If you want your new version to be looked at, better file a new patch.

This issue still exists in CVS build 14/09/2006. I tried a fresh install with the build and the latest fonts. Someone please fix this so I can use a newer build. Please please please! :)

This bug is still present in build 23/09/2006. Does it have to do something with pictures and text at the same place?

I can not confirm any flicker. On my Iriver H100 it just displays the icon for the filetype and the other time it is blank, or shows one “.”. I assume this is the decimal point for the bitrate.

I also recently tested the CVS build from 24/09/2006 and got the same result as you. I was playing an MP3 and got the MP3 graphic on the remote’s screen (bottom right corner) but that’s all. I think I may have mistaken the dot for a flicker. I have reverted back to the 24/08/2006 build for now. The iAmp RWPS normally iterates through: x of y play list count, bitrate and file type graphic (I believe). I’m not sure where the problem lies, it could be with the iAmp theme itself. I really want this fixed so I can use a newer build. I think the iAmp theme is great and it gives me exactly what I need.

Tested the CVS build from 20/10/2006 and got the same result again. I was hoping someone would have fixed this by now or fixed it indirectly by another update. I can’t believe no-one else has noticed this!

Tested the CVS build from 16/11/2006 and got a similar result again. The dot seems to have disapeared now. I’m bored of this problem now, still using the 24/08 build. Someone please fix this! :-/

The wps topic got me interested to investigate (don’t have a H1x0 and couldn’t use iAmp) but the problem shows in the sim too.

While looking at it I could see:
nothing, then the filetype bitmap, then the already mentioned dot - changing each 3 seconds like in the subline definition.
My impression is that the textual info (playlist position/playlist entry in the first subline - bitrate info in the third subline) is hidden by an empty solid rectangle in place of the filetype bitmap that is part of the second subline.

I looked through the list of commits (”since 1st August” on the front page) what changed between August 24th and September 5th and found the last commit to gwps-common.c by Magnus Holmgren (Lear/learman) on Aug 29th, that could have an influence on that behaviour. To prove this theory I checked out revision 10792 (the one right before) - compiled a sim and tested iAmp and it worked as expected; then I “updated” to revision 10793 - tested it again and iAmp remote wps was broken. Hope it helps someone knowledgeable of the code to fix it.

(Btw. one of you who noticed early enough that it was a change during this time that caused it, could have tested with daily builds to narrow the period down to one day - as long as they were part of the last 30 dailies which are available.)

r commented on 2007-03-25 23:48

Hi Marianne,

Actually, the “empty solid rectangle” is the place where the following preloaded bitmaps, “Pause”, “Fast Forward” and “Rewind” would load to if the user either paused, fast forwarded or rewinded a track.

If you remove the code for those preloaded images and the Playback mode tag, you should see more of the textual info on the rotating lines.

However, the “codec” images also cover the textual info (playlist position, etc.).

Hopefully a developer/programmer can address this issue, as it is one of the reasons why I did not release a new version of iAmp since late 2005.

Thanks for narrowing down the time frame as to when this bug occurred, Marianne!

r commented on 2007-03-26 00:44

Okay I just looked at the differences between revision 10792 and subsequent revisions for “apps/gui/gwps-common.c”

and there seems to be changes to these lines:

on line 1382 (revision 10792):
skip_conditional(NULL, fmt, 0, &intval);

has changed to the following on the new revisions (currently on line 1406):
skip_conditional(gwps, fmt, 0, &intval);

also on line 1396 (revision 10792):
fmt = skip_conditional(gwps, fmt, 1000, NULL);

has changed to the following on the new revisions (currently on line 1420):
fmt = skip_conditional(NULL, fmt, 1000, NULL);

and lastly on line 1399 (revision 10792):
fmt = skip_conditional(gwps, fmt, intval - 1, NULL);

has changed to the following on the new revisions (currently on line 1423):
fmt = skip_conditional(NULL, fmt, intval - 1, NULL);

if these values were reverted to those from revision 10792, would that fix the remote bitmap issue?

r commented on 2007-03-27 01:12

regarding the previous post:

this shows you the exact differences!
sorry for the additional comment! first time using SVN!

This issue seems to be getting worse, not better. I’d hoped someone would have been able to fix this issue by now. There are more issues now and with other themes like Marquee and Marquee Adapted. iAmp still isn’t working properly either. The issues are all with the RWPS on my iRiver H140. It appears there are alignment with elements that make up the screen and the issues have appeared sometime since the new menu structure was launched (sorry for the lack of time specific information).

I don’t update very often but am happy to assist anyone who is able to look into this. I can test and provide feedback.

r commented on 2007-05-01 21:37

i’m beta testing iAmp 2.0 and everything seems to be going fine! :)
a public update will be made once i have made all the new codec images… been too lazy to make them! :p

Great news! I can’t wait for the updated fixed version as iAmp is my favourite theme :)

If you want another tester before you release the final version let me know.

Any news on iAmp 2.0? I’m still desparate for it and iAmp is by far the best!

Right, I’ve worked around this bug for iAmp 1.0. The code for preloading the “Pause”, “Fast Forward” and “Rewind” bitmaps needs to be above the line where play list counts, file format logo and bitrate is displayed. Next the decision for displaying the “Pause”, “Fast Forward” and “Rewind” bitmaps needs to be moved to the start of the same line as where the play list counts, file format logo and bitrate display code is. Fixed! (well, worked around at least!)

The “empty solid rectangle” must be some kind of remainder (or place holder) of the images which were there but are subsequently hidden. This obviousy wasn’t a problem when iAmp was originally developed and must have been introduced in a later Rockbox build. Is it a bug or a feature?

r commented on 2007-07-28 00:29

Hey Rich, glad to hear you found a workaround! :)
Was this done on the latest build of Rockbox?

Sorry about the delay for iAmp 2.0, i must say i’m getting lazy as the days go by!
I’ve been using an old build from late March when i was doing my testing before.

So I guess I need to test it out on the new dailies as well!
I’m a little hesistant to do so, but that brand-new WMA support looks really tempting! :)

Will try and get iAmp “deux” up by the end of the weekend… if not, then the week after!

Hope you can wait a little longer!

r commented on 2007-07-28 22:05

Christmas in July!

iAmp (deux!) released!


   iAmp2.rar (29.2 KiB)
r commented on 2007-07-28 22:08

forgot to say that iAmp (deux!) works on the newest builds… last tested with the July 27th build.

Cool, well done. I’ll have to check it out. I’m still running an old build of Rockbox from April 2007 because the current builds crash when car adaptor mode is in use.

I modded iAmp 1.0 myself to include a few extra details (like play count) and changed the volume display to numeric.

Thanks for the credit in your readme.txt :)

Are you sure you want to close the task? It is still a bug / issue, the difference is we can work around it now! I guess it’ll be even lower priority to fix if it remains open and it’s been open almost year already!

Sorry for the slow response, for some reason no email notifications of new posts were coming through?!

r commented on 2007-08-08 21:49

Hey Rich,

Good to hear you have modified iAmp to your liking! As for the emails, maybe SVN just doesn’t like me!

The reason why I didn’t add the numerical volume in the RWPS was because of the font being too large; if Rockbox ever supports dual fonts, this would be changed! As for play count, I do not use Rockbox’s database feature! ;)

Forgot to mention in the readme that the RWPS now includes a virtual disk LED. So if Rockbox is accessing the hard drive, you can now tell!

About closing the task, it could be that I previously exploited a function of Rockbox before, so it might well be that iAmp is the one that is causing the problems and not the other way around… In the end, it is up to the devs if they want to close it or not.

And btw, no need to thank me for the credit! ;)

The original issue as described in the first report and title seems to be fixed now - since the recently committed AlbumArt showed the same effect and the developer took the time to fix it a few days later. That means the svn iAmp version works correctly now again.

I would suggest to close this bug report and if you still want to submit a new version, then file it as a patch. If there are no objections or comments in the next days, I’ll close it.


Available keyboard shortcuts


Task Details

Task Editing