Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Bootloader
  • Assigned To
    barrywardell
  • Operating System iriver H10
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by 718unique - 2006-09-08
Last edited by barrywardell - 2007-08-01

FS#5955 - H10 Rockbox doesn't work on early models

Hi, I was looking forward for this project, but it seems that i have to wait a bit longer.
The problem is your fantastic Rockbox for H10 doesnt’ work on early models of h10.
This isn’t just my problem, but of many others too. I’ll tell you what happened.

I have fully installed your program but unlike others, some of us were having problems. It turned out to be the ones
who were using an early model (with a SRS wow sticker, not a tattoo). When we installed and turned out machines on
only this will appear and no progress would be done.
this is what appears –»>

                          Rockbox boot loader
                          Version: 20060905-094~   <- ~ part was off the lcd
                          iriver H10
                          ST650211FX

Know what’s wrong with this? I hope me and my friends could use you Rockbox soon.

Closed by  barrywardell
2007-08-01 20:38
Reason for closing:  Fixed
Additional comments about closing:  

Sounds like this isn't a problem any more. I can reopen this task if people report still having problems.

Which model H10 do you have? I’ve had a report of this from a user with a 5GB Pure model. He’s having exactly the same problem.

Also, which firmware version are you using? Is it UMS or MTP? Which region - Eurpoean, US or Korean?

I have apparently the same problem as above, my config is as follows:

H10 5GB UMS from Europe
I assume that I bought the this about 5/05

The error messages are
Rockbox boot loader
Version: 20060905-094… iriver H10
ST650211FX
Partition 0: 0x0B 476… Rockbox error: -1

bye, Alexander

Alexander, you are having a different problem than is reported above. Rockbox error -1 means that the bootloader can’t find the rockbox.h10 file. That is not a bug with the bootloader.

Hi, having the same problem (the original error, not the “error -1” one) with mine, it gets stuck on exactly the same screen. I dodn’t think my player (H10 5GB) was that old - about 6 months, maybe a bit more, although I guess it may have been sat in a warehouse or something for a while before I got it! It also doesnt appear to have any SRS wow markings on it at all.

I’ve tried it with both 2.51 and 2.10 MTP firmwares installed, I think the 2.51 was european, 2.10 was US, and get exactly the same error.

Has anyone made any headway on working out the reason for this problem?

Let me know if there’s anything else I can do to help!

after the comment by barry, I tried a different bootloader file (not the one that is in the daily build zip) and kept all files in the .rockbox directory and I at least got the system to boot up. However I couldn’t access any menu options, so I reverted to the normal iriver system.

Unfortunately recently my player broke, probably due to a HD failure, so I cannot test this anymore (and I have now bought an ipod nano).

Hi, I’m having the same problem with the original problem.
I’m using, H10 5gb color, UMS, firmware 2.53 Japanese.
I’ve tried English firmware but the screen stops with the same words.
It appears on screen like this

Rockbox boot loader
Version: 200612-19-151… iriver H10 5/6GB
ST650211FX

I bought this few days ago at Japan.

Is this still a problem? Can someone who had the problem before please try again with the latest SVN build (and latest bootloader) and see if it is still present?

yes, seems to be working fine for me now (see comment above), well done guys!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing