Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Recording
  • Assigned To No-one
  • Operating System All players
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by polluxx2006 - 2006-09-09

FS#5961 - crash while recording

model: iriver H140
build: CVS-060907

hi developers. i encountered several problems with recording. it crashed while trying to record radio
or just with microphone. for example, i turn on the radio, choose source=fm radio, adjust the gain and
then it crashes. there was the following message:
I05: at 310205F8

also, i recorded somethin in wavepack, turned on time split and set it to 01:00… but the file i had
later was 01:09…

Closed by  mmmm-
2006-09-13 18:22
Reason for closing:  Fixed

The same here, very reproducable with rockbox-daily-20060909.
IO5: at 310205A0

This does not happen at all when I use m68k-elf-gcc-elf 3.4.3 and old configure script
compiling the rockbox-daily-20060909 source.

So I suspect the compiler or the new configure script.

Hm… IO5, that must mean a division by zero error. Previously, “software” divide was used, and wouldn’t trigger that exception. Now it can happen, and the function read_peak_levels seems to be the most likely cause for it (only loosely based on map file examination, so I could be wrong…).

mmmm- commented on 2006-09-13 12:12

Does this patch fix it ok? I can’t seem to reproduce this problem at all!

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

Yes, patch applied to rockbox-daily-20060909 fixes the problem.
Seems to be also better than my fix: http://www.rockbox.org/tracker/task/5972

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing